[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: firewire, iPod and Linux

On Fri, Jul 16, 2004 at 04:13:51PM -0700, Erik Steffl wrote:
> Emma Jane Hogbin wrote:
> >Ok, this worked (yay!!) but it is read-only. I found a document which said
> >the partition may need to be cleaned first on a Mac, but I tried this and
> >it didn't help.
>   I didn't have to clean anything on mac (I don't even have access to a 
> Mac)
>   what happens if you explicitly try to mount the partition as rw:
> mount -t hfsplus -w /dev/sda3 /mnt/ipod

Same thing...it's still read-only.

>   do you have a line in /etc/fstab for ipod? (if yes, does it say ro?) 
> this is what I have in /etc/fstab for ipod:
> /dev/sdb3       /mnt/ipod     hfsplus rw,user,noauto             0  0

I haven't been using an entry in my /etc/fstab. I've just been trying to
load it "by hand".

Ths time the iPod ran out of battery while I was trying to work things out
and now I can't umount it and I get the following errors when I try to
read the files:

smeagol:~ 09:13:59 $ ll /mnt/ipod/
ls: /mnt/ipod/Calendars: Input/output error
ls: /mnt/ipod/Contacts: Input/output error
: Input/output error
ls: /mnt/ipod/Notes: Input/output error
total 0
drwxrwxrwx    1 99       99              6 Jul 10 10:35 iPod_Control

And I can't properly unmount it anymore. It says:
	smeagol:~ 09:15:50 $ sudo umount /mnt/ipod
	umount: /mnt/ipod: device is busy

Who knew that winning an iPod would be so difficult. :(

thanks for your help!

Emma Jane Hogbin
[[ 416 417 2868 ][ www.xtrinsic.com ]]

Reply to: