[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

debootstrap finally works, i think



Hi, all --

I believe I have finally gotten somewhere with debootstrap.  What a PITA
this has been.

For review, I have a somewhat interesting piece of hardware with no CD,
video, or keyboard, and I not only want to be able to install a major
*NIX release (where I don't have to do all of the building and package
maintenance and security fixing but can instead just leave it to the YAST
Online Update or apt-get or whatever) on it but also update it in the
future all without having to take it apart and find some desktop PC into
which to shove the hard drive to boot from CD.  Enter debootstrap.

As if that weren't challenging enough, I am quite a nervous nellie about
this server since it is a central data, web, and backup as well as
external login server for the house, so I'm going to practice this on a
scratch machine first.  The server is running an LFS build while the
scratch box is running SuSE, but that's immaterial.

Finally, since I 1) live at the bottom of a very lousy DSL well, 2) plan
to do this several times, *and* 3) want to ensure that I'm working with
the same snapshot each time so that it will really work when I do the
real thing, I want to locally mirror enough debian tree to be able to
install without depending on the outside world.  Despite helpful advice
here and there, this has proven a most excruciating exercise.  I tried
various options to debootstrap including

  --download-only

to attempt to build a suitable mirror, tried mirroring a debian mirror
on my production web server so that I could pick and choose as I pleased
but gave up after some 38G (good grief!!), and finally figured that the
woody (stable) ISO images MUST have a sufficiently complete set of files
and that I would go ahead and use those rather than continue to attempt
to install sarge (testing).  That, and a bloody lot more download time,
brings us to today.

First I downloaded half a dozen woody images plus an upgrade, and with
the loopback device to mount them I one by one extracted all of those
into a directory on my server and made it available under http://debian/
for my debootstrap to use (with the proper 'debian' entry in /etc/hosts,
of course).  Since everything under dists/ was a symlink to woody, I used

  debootstrap -arch i386 woody /mnt/suse81 http://debian/
  
to try to install woody.  Unfortunately, the first thing I got was

  I: Validating debootstrap.invalid_dists_woody_Release
  E: Invalid Release file, no entry for main/binary-i386/Packages

and debootstrap very much stops.  Sheesh.  What's up with that?

After banging around a bit, I went and got

  http://http.us.debian.org/debian/dists/woody/Release

and put it in place of my existing Release file on the server and tried
again.  Then I had trouble with Packages, so I got

  http://http.us.debian.org/debian/dists/woody/main/binary-i386/Packages.gz

and put it in place and extracted it to an uncompressed version.

Finally I ran

  debootstrap -arch i386 woody /mnt/suse81 http://debian/

one last time and as promised in the debootstrap howto at

  http://trilldev.sourceforge.net/files/remotedeb.htm

I got to

  I: Base system installed successfully.

to start my chroot shell.  Woo hoo!

What a freaking nightmare.  I sure hope this helps someone else who is
trying to figure out how to use this thing.


Thanks for all the help & HAND

:-D
-- 
David T-G
davidtg@justpickone.org
http://justpickone.org/davidtg/      Shpx gur Pbzzhavpngvbaf Qrprapl Npg!

Attachment: pgpJzoeEVeIwA.pgp
Description: PGP signature


Reply to: