[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: problems with sound

Hi Eric!

On Mon, 31 May 2004, Eric Cheney wrote:

> On Monday, 31 May 2004 at 21:22:49 -0500, dircha wrote:
> > Eric Cheney wrote:
> > >Hi People. I am trying to get a box up and running and am stuck with
> > >sound problems. I compiled a new 2.6.6 kernel kernel.org and the
> > >kernel seems OK. The sound card is a sound blaster live and I 
> > >compiled that into the kernel; along with the mixer and stuff. I'm 
> > >using ALSA. On boot, the kernel recognizes the sound card. However,
> > >when in GNOME I test the usage of the card with XMMS. I get an error
> > >message that pops up that says
> > >
> > >        o   You sound card is configured properly
> > >        o   You have the correct output plugin selected 
> > >        o   No other program is blocking the sound card
> > >
> > >OK, I checked /dev/dsp and it is there. Also, I'm doing this as root,
> > >so I don't think it is a permission problem. I've searched the net
> > >via google and the debian mail archive and either I'm missing points
> > >people have made, or .... I dunno. I'm stuck.
> > 
> > I've heard good things about alsaconf (in alsa-utils), although I've 
> > never used it myself. It will attempt to automatically generate a 
> > configuration for your card.
> > 
> > You'll need to execute it as root.
> Thank you.  I gave it a shot.  It says it could not find a pNp pci
> device and complained that it couldn't find the snd module.  OK,
> that makes sense because I compiled the alsa stuff directly into the
> module and my sound blaster live card is embedded in the system
> board.  So still no sound.  

There is a snd.o module.  This module is loaded by the emu10k1 module
when I load it on my system.  Maybe you didn't get it compiled in?

If your just testing using xmms you should make sure that xmms is
using the correct Output Plugin in the Preferences.  Have you tried
playing a wav file with the 'play' command?

Personally I just put emu10k1 in my /etc/modules file and my SB Live
works great.  Last time I used alsa it was more of a pain than it was

Cocaine is gods way of telling you that you make too much money.

 B. L. Jilek F92D0DD1  | Reap the Freedom!  Use Linux!  |  ICQ: 83785391
 bljilek@topazcrow.com |      Check out this site.      |  Yahoo: bljilek
 www.topazcrow.com     |   http://www.againsttcpa.com   |  AOL: brianleejilek

Attachment: signature.asc
Description: Digital signature

Reply to: