[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Debian Lexmark Z25 Z35

This is for the archives, so the next person unfortunate enough to be faced 
with one of these wretched printers can spare himself several arduous hours.  
It has a penguin on the box, and they do have a driver, but getting it to 
work on a Debian system was not the most pleasant way I've ever spent a 
Sunday afternoon.

I finally found the key to this mystery on a Gentoo forum 

I'm copying the text here and making minor changes to adapt it to Debian.  I 
haven't been crazy^h^h^hbrave enough to try a 2.6 kernel yet, so I can't 
vouch for the bit added on at the end.  This worked beautifully on Sarge with 
a 2.4 kernel.

> Posted: Fri Dec 26, 2003 10:44 pm    Post subject: Lexmark Z25 or Z35 
printer setup
> Last edited by CdWhistler on Tue Mar 16, 2004 7:41 pm; edited 5 times in 
> After trying many things I concluded that the lexmark installer sucks. I 
found a start here: http://www.linuxprinting.org/lexmark-faq.html but it was 
for old drivers. So here are my new instructions that work for gentoo. This 
is not a usb printing step by step guide. This guide assumes you have the 
correct kernel setup and have cups working. I have a Z25 printer I tested 
this with but the Z35 should work the same since they use the same drivers. 
>  1.Download drivers from: 
>  2.Open a terminal and extract the file with 
>  cdwhistler@host cdwhistler # tar -zxf CJLZ35LE-CUPS-2.0-1.TAR.GZ 
>  3.Extract the driver files 
>  cdwhistler@host cdwhistler # ./lexmarkz35-CUPS-2.0-1.gz.sh -target temp_lex 

You may get an error here.  If you have two RPMs in the temp_lex directory, 
then you can safely carry on.
>  4.Convert the rpms' in the temp_lex folder to a tar.gz by running: 
   cdwhistler@host cdwhistler # cd tmp_lex
   cdwhistler@host cdwhistler # alien --to-tgz *.rpm 
>  5. Su to root 
>  cdwhistler@host cdwhistler # su 
>  6.Extract the drivers to root: 
>  root@host root # tar -zxf lexmarkz35-CUPS-2.0-1.i386.tar.gz -C / 
>  root@host root # tar -zxf z35llpddk-2.0-2.i386.tar.gz -C / 
>  7. Change to the z35 driver folder 
>  root@host / # cd /usr/local/z35llpddk/utility 
>  If there is a bnsi1,2, or3.lut file, remove it 
>  8. Link your locale (Only choose one) 
>  root@host utility # ln -s auckUS.lut bnsi1.lut for US 
>  root@host utility # ln -s auckEU.lut bnsi2.lut for EU 
>  root@host utility # ln -s auckAS.lut bnsi3.lut for AS 
>  9. Change to /usr/lib directory 
>  root@host utility # cd /usr/lib 
>  10. Create symlinks for some of the libraries 
>  root@host lib # ln -s liblexz35core.so.0.0.0 liblexz35core.so.0 
>  root@host lib # ln -s liblexz35printer.so.0.0.0 liblexz35printer.so.0 
>  root@host lib # ln -s liblexz35printjob.so.0.0.0 liblexz35printjob.so.0 
>  11.Check to see if the driver detects your printer: 
>  root@host lib # /usr/lib/cups/backend/z35 
>  12.Output should look similar to this: 
>  direct z35:/dev/usb/lp0 "Lexmark Inkjet color printer" "Lexmark Printer" 
>  13.If it says anything about missing libraries, make sure they are 
installed and symlinks were created correctly. 
>  14.Run the paper alignment utility to make sure it is working: 
>  root@host lib # /usr/lib/cups/backend/z35 utilities 
>  15. Restart cups and add the printer through cups but choose the Lexmark 
Printer port, not the the usb port. Also choose the Lexmark driver (duh). 
Then everything should be working. 
>  Let me know of success or problems. 
>  Go my Z25 to work with 2.6 kernel and udev. Add this 
to /etc/udev/udev.rules as the last thing before the devfs rules start. 
> Code:
> BUS="usb", SYSFS{idVendor}="043d", SYSFS{idProduct}="0057", NAME="usblp%n", 
>  If this does not work run : 
> Code:
> udevinfo -a -p /sys/class/usb/lp0
>  and see if the idVendor and idProduct are the same as mine (they should 
be). If not replace your idVendor and idProduct in the udev rule. 

Some notes...  After setting up the printer, try a test page.  If it comes out 
OK, you're fine.  If you get ugly venetian blind effects and the blue ink is 
all screwed up, then configure CUPS to default to 1200 dpi and try again.  I 
did two of these.  One worked at 600 dpi, and the other didn't.  Switching to 
1200 or 2400 dpi fixed it.

I don't think it's possible to use the GIMP print driver with this printer.  
Printing web pages and color bits from Open Office seems to work fine, and 
plain text from various other sources seems completly fine as well.

Cheap color capability for $23, and it works.  But you have to agree to a very 
unDebian-like license, and it only works with these proprietary drivers.  
Without them it's not even heavy enough to make a good boat anchor, so it's 
just landfill fodder.
Michael McIntyre  ----   Silvan <dmmcintyr@users.sourceforge.net>
Linux fanatic, and certified Geek;  registered Linux user #243621

Reply to: