[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: 2.6.5 -- I broke the internet

Emma Jane Hogbin wrote:
> Nono, it found my card just fine. But what isn't working is the auto
> detect scripts. Rico on debian-laptop suggested I configure things by
> hand, and that worked.
> ifconfig eth0 netmask
> route add default gw
> I'm not sure how to do anything useful with that information, but now
> I have an internet connection so life is better.
> emma :)

I once had something similar but for me the issue was cause by not
having "auto eth1" in my /etc/network/interfaces file.
After adding that ifup command worked.

However since you already have this stance, it must be something else
(duh i'm a real Sherlock here :)). Are you sure your dhcp is working?
Since eth0 is active after adding a fixed ip, but not when an ip is
requested via dhcp, dhcp might be the issue?
Is the dhcpd daemon running? Is /etc/default/dhcp configured
Nothing strange in /etc/dhcpd.conf?


Reply to: