[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: libxrender-dev fails to install using apt-get install or aptitude in Sarge - solved I hope

I believe I solved my own problem.  I removed the following lines out of
the /var/lib/dpkg/diversions file:


libxrender-dev now installs without any errors.

On Sun, 2004-05-02 at 10:27, stebe@juxtaposition.dynip.com wrote:
> I'm attempting to install the libxrender-dev package in Sarge I get the
> following error. 
> Unpacking libxrender-dev (from .../libxrender-dev_0.8.3-7_i386.deb) ...
> diversion of /usr/X11R6/include/X11/extensions/Xrender.h to
> /usr/share/libxrender1.1/diversions/Xrender.h by libxrender-dev
> dpkg-divert: mismatch on divert-to
>   when removing `diversion of
> /usr/X11R6/include/X11/extensions/Xrender.h to
> /usr/X11R6/include/X11/extensions/Xrender-1.1.h by libxrender-dev'
>   found `diversion of /usr/X11R6/include/X11/extensions/Xrender.h to
> /usr/share/libxrender1.1/diversions/Xrender.h by libxrender-dev'
> dpkg: error processing
> /var/cache/apt/archives/libxrender-dev_0.8.3-7_i386.deb (--unpack):
>  subprocess pre-installation script returned error exit status 2
> I've done a search for Xrender.h and Xrender-1.1.h and neither files are
> installed.  apt-get -f install comes back with the same error
> This system was originally running stable and I did a dist-upgrade last
> December and I've not had problems until now with installing packages.
> What options are available to me to get around this problem?
> -- 
>   <stebe@juxtaposition.dynip.com>

Reply to: