[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

apt-get upgrade chokes in alien package

I can not upgrade my system because of some supposed unmet dependency of
one package:
Sorry, but the following packages have unmet dependencies:
  libbatik-java: Depends: j2re1.4 but it is not installable or
                          j2re1.3 but it is not installed or
E: Unmet dependencies. Try using -f.
It so happens that some Java packages require a newer Java than is
available from Woody itself.  So I had installed the Sun J2RE by
converting their .rpm to .deb with alien, and installing it.  dpkg knows
all about it:

dpkg -p j2re
Package: j2re
Priority: extra
Section: alien
Installed-Size: 55322
Maintainer: root <root@tompth.xs4all.nl>
Architecture: i386
Version: 1.4.1_04-1
Depends: libc6 (>= 2.3.1-1), libstdc++2.9-glibc2.1, xlibs (>> 4.1.0)
Size: 21855114
Description: Java(TM) 2 Runtime Environment, Standard Edition
 The Java 2 Runtime Environment consists of the Java
 virtual machine, the Java platform core classes,
 and supporting files. It is the runtime part of
 the Java 2 SDK, but without the development tools
 such as compilers and debuggers.
 The JRE is freely redistributable, per the terms
 of the included license, when bundled with Java
 applets and applications.
 (Converted from a rpm package by alien.)

Nonetheless, apt-get does not seem to recognise that this package fulfills
the dependencies of libbatik-java.

What am I supposed to do about this?

	Tom "thriving on chaos" Peters

Reply to: