[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Root Password No Longer Works in KDE

Scarletdown wrote:

Earlier today, I had a complete system freezeup for some reason. All I could do to recover was power down and boot back up. However, when kdm tried to run, I was dropped to a text login prompt.

I went ahead and logged in as root and did an apt-get --reinstall install kdm; then i ran kdm and was able to get to the graphical login screen. When I logged into the KDE desktop, I discovered that I was unable to do anything that required the root password (su, kpackage, etc). I keep getting "Authentication failure".

I know the password is good, because I am able to login as root from a text-prompt, and can also SSH in as root from another system; so I am suspecting a problem with KDE itself. As another test, I tried logging in to KDE as root from kdm, and that fails as well.

And even more odd is, everytime I reboot, kdm fails and drops me to a text-based login, and I have to once again do an apt-get --reinstall install kdm.

I have tried everything I could think of at the moment, short of doing the dreaded OS reinstall (apt-get --reinstall install x-window-system kde and apt-get --reinstall install kde did not fix it either.) I would really prefer to not have to reinstall, since it took me forever the first time around to get the nVidia video drivers configured right, and I can't remember whether or not I took down notes on how I did it.

So, if anyone here can make sense of my rather rambling description of this root password problem, please give some advice on how to get things back to normal. Thanks.

Just a random thought. Did you try changing LDAP (server/client) configuration? May be the difference between /etc/pam.d/su and /etc/pam.d/ssh would give you an idea.

Home page: http://www.people.cornell.edu/pages/kk288/index.html
Fluid's group: http://groups.yahoo.com/group/flumech/

Reply to: