[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Problem with scsi emulation

I'm running Woody (2.4.22) and have two cd-roms.  The first
(/dev/scd0 mounted at /scsi) is a genuine scsi drive and I
have no problems with it.  The second is an IDE dvd-writer.
 I enabled scsi emulation and put an entry for it in my
fstab as /dev/scd1, mounted at /dvd.  

Before I emulated scsi, I referred to it as /cdrom and it
worked fine.  However, when I changed to the scsi emulation
I couldn't get /usr/sbin/base-config to work.  Every time I
try to install a package, it wants me to insert my debian
cd in /cdrom which it couldn't find.  Same thing happened
with ripperx.  Whenever I start ripperx it complains that
it cannot find the cd-drive.  

I tried making symlinks (/dev/scd1 -> /cdrom, /dev/scd1 ->
/dev/cdrom and /dvd -> /cdrom).  It didn't solve the

Because I had symlinks all over the place, I tried to tidy
it up a bit and ended up deleting /dev/scd1.  Not knowing
how to get /dev/scd1 back, I renamed /dev/scd16 to
/dev/scd1.  Now I cannot mount my dvd-writer.

I have two questions:

1.  How can I correctly recreate /dev/scd1?
2.  How can I get apps that point to /cdrom to access /dvd
(or /dev/scd1)?

Please note:  I have been told not to use base-config, but
that's not the point of my question.  Whether I use it or
not is irrelevant.  The point is that I cannot use it and I
would like to have the problem fixed.

Any help and advice will be appreciated.

Cut out the middle man with Dial Direct Insurance, click here for a free e-Quote!

Reply to: