[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Software RAID problems (bad filesystem type)

Timo Railo wrote:

> Hi!
> I'm having problems getting software raid to work with my IDE drives. I
> had Redhat9 installed previously on the same machine (with working
> software raid setup), but I'm now moving to Debian.
> My kernel is 2.4.18-bf2.4 and has support for RAID1, which I'm trying
> to create. I'm following these instructions (thank you Lucas for
> excellent instructions!):
> http://www.cs.montana.edu/faq/faqw.admin.py?
> query=1.22&querytype=simple&casefold=yes&req=search
> All goes well up to point 8 (I'm able to create raid, put ext3
> filesystem on it and even mount it). But that's only the first mount.
> After reboot, when trying to mount, I get this error message:
> "mount: wrong fs type, bad option, bad superblock on /dev/md0,
>         or too many mounted file systems
>         (could this be the IDE device where you in fact use
>         ide-scsi so that sr0 or sda or so is needed?)"
> I've tried zeroing the superblock, with no help. Also tried recreating
> the partitions (times x) and tried recreating filesystem.
> Please help, I'm really running out of ideas.
> Thank you very much,
> Timo Railo

I recall seeing a similar (or the same) error message when I tried to do the
same thing.  I don't know much about builing an initial ram disk, but I
gather that you've somehow got to get the raid drivers into the initial ram
disk for this to work.  What ended up working for me was compiling my own
kernel, with all RAID functionality built in, instead of in modules.  I was
never able to get the stock (or bf2.4) kernel to work.

I know that's not exactly the solution to your problem, but I hope you find
it useful, nonetheless.

Justin Guerin

Reply to: