[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Iptables can't locate its modules

On 16 Dec 2003, Antony Gelberg wrote:
> On Tue, Dec 16, 2003 at 09:43:06AM +0000, Anthony Campbell wrote:
> > I'm trying to set up iptables using kernel 2.4.23. I've installed
> > iptables and iptables-dev from testing and I've enabled CONFIG_NETFILTER
> > but all attempts to execute the iptables commands produces:
> >
> > root:~:# iptables -F
> > modprobe: Can't locate module ip_tables
> > iptables v1.2.9: can't initialize iptables table `filter': iptables who? (do you need to insmod?)
> > Perhaps iptables or your kernel needs to be upgraded.
> >
> > Google produces various references to this problem but no solutions that
> > I can see. Should I have included other things in the kernel? Any simple
> > documentation for this?
> >
> > Or is it perhaps overkill for a standalone machine, albeit one that is
> > constantly connected to the met?
> No, you need it.  I would compile iptables and associated sub-options as
> modules, rather than straight into the kernel.  That was you don't need
> to recompile if you decide to use different iptables features.
> And use this to generate your script.  http://morizot.net/firewall/gen/
> It's the way forward.
> A

Thanks for this useful link. Meanwhile I'v managed to get iptables
running. I was using a kernel generated by a patched 2.4.22. I tried a
vanilla 2.4.23 and it worked fine.


ac@acampbell.org.uk    ||  http://www.acampbell.org.uk
using Linux GNU/Debian ||  for book reviews, electronic 
Windows-free zone      ||  books and skeptical articles

Reply to: