[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

permamently load a network module

I have configured my network to use a driver, however when the computer restarts it no longer has the network.


I installed the driver as follows:

/etc/init.d/networking stop

copy the module to /lib/modules/2.4.18-bf2.4/kernel/drivers/net

/sbin/insmod /lib/modules/2.4.18-bf2.4/kernel/drivers/net/eepro100.o



(shows that the module is loaded)


I then configured the /etc/network/interfaces the way I wanted it.


/etc/init.d/networking start

no errors


ifconfig shows my new interfaces eth0 and lo

eth0 is the one I am trying to configure.


I can ping other computers on the network.


When I restart eth0 does not show up in ifconfig.  The module does not show up when /sbin/lsmod is ran.

If I run the networking start command after reboot it tells me that eth0 and lo are configure correctly.  However still no output from ifconfig or any network access.

Sorry about the long post, but I wanted to be as thorough as possible.


Reply to: