[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Network unreachable

On Sun, 2003-11-02 at 09:50, Jeffrey Barish wrote:
> Marshal Wong wrote:
> > On Sat, 2003-11-01 at 20:21, Jeffrey Barish wrote:
> > 
> >>When I use the kernel that I built from the source for 2.4.18-686, I get 
> >>the message:
> >>
> >>sendto: Network is unreachable
> >>
> >>when I try to ping another machine on my network.  Using ifconfig, I 
> >>noticed that eth0 had no IP address assigned.  So I did
> >>
> >>ifconfig eth0 down
> >>
> >>and then
> >>
> >>ifconfig eth0 netmask up
> >>
> >>At that point, ping worked.  So it seems as if dhcp is not working.  Is 
> >>there something in the kernel configuration that is required to make 
> >>dhcp work? 
> >>
> >>I am still not able to browse the web.  I get the message "Could not 
> >>connect to host ..." no matter what URL I use.
> >>
> > 
> > 
> > I've noticed that dhcp doesn't change any configurations.  If I run
> > dhclient, it spews out the information for the dhcp, but that's it.  It
> > doesn't change any network settings.  It's been that way for a long time
> > now, but I've just worked around it...  Good to know that someone else
> > is having the problem...
> > 
> > Anyways, to help you with the "Could no connect to host..." problem, you
> > probably need to add a default gateway to your routing table.
> > 
> > Check if the default gateway is reasonable using
> > 
> > # route (as root.  Haha!)
> > 
> > If not, then
> > 
> > # route add default gw <ip.address.of.gateway>
> > 
> > Good Luck.
> > 
> > Marshal
> Your suggestion solved the problem.  I also had
>    auto eth0
>    iface eth0 inet dhcp
> in my /etc/network/interfaces, but the routing was not correct until I 
> issued the route command manually.
> I still don't understand why there is a difference depending on whether 
> I boot the kernel that I built from 2.4.18-686 source or use the 
> standard kernel in that distribution.  The standard kernel gets 
> everything right without my issuing the ifconfig and route commands. 
> Also, I see dhclient running with the standard kernel.  I'm thinking 
> that the problem when I run my kernel that requires the ifconfig and 
> route commands arises because dhcp doesn't run, and dhcp doesn't run 
> because something is not configured correctly in my kernel.  What do I 
> need to turn on when I configure my kernel to get dhcp?  Is there some 
> other explanation for why dhcp doesn't run with my kernel?

You know, that could be where the problem is, because I didn't have that
problem until I started playing around with my kernel...

Unfortunately, I'm in the same position as you.  I have no idea why it
would make a difference.


Attachment: signature.asc
Description: This is a digitally signed message part

Reply to: