[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: How to fix: glibc installed over libc6 broke system

On Sat, Nov 01, 2003 at 08:19:06AM -0600, John Foster said
> I did a real dumb thing without thinking. I grabbed a .rpm of glibc 
> 2.3.9 from SuSE, converted it to a .deb with alien and installed it. Of 
> course I forgot that libc6 is the debian way of handeling this 
> dependency (see locales; unstable) Yeah it was VERY late.

You really should never, ever, ever, ever, ever touch libc6, especially
installing random crap over the top of it.  As you discovered,
everything else depends on it working flawlessly.

> Any way it broke the entire system. i tried to reboot got a kernel panic 
> no init sequence. 

Unless you have "sash" (stand-alone shell, which is statically linked)
installed, you won't be able to boot into your system at all; every
binary requires libc6 to be installed and working.

> I also tried to chroot to the files system from another stable system
> disk in the same box. 

chroot'ing may not work either.  Try using 

"dpkg-deb -X libc6_from_debian_not_suse.deb /place/you/mounted/your/broken/system" 

from your stable system to get a basic Debian libc6 back.  Try to use
the one what was installed before the broken RPM was.  Note that this
will only extract the .deb, not perform all the associated setup.  Once
you get your system to a state where you can at least chroot into it,
reinstall the exact same deb with "dpkg -i" so it's install scripts get

Ah, before this, save
/place/you/mounted/your/broken/system/var/lib/dpkg/info/glibc.list so
you have a list of files from the broken rpm/deb that you can cleanup

> No go. ANT tips or ideas are aooreciated.

Tip: don't ever overwrite your C library :-)

Rob Weir <rweir@ertius.org> | mlspam@ertius.org  |  Do I look like I want a CC?
Words of the day:      ASO FTS2000 Ermes ANZUS kilderkin BRLO Watergate quarter

Attachment: signature.asc
Description: Digital signature

Reply to: