[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

custom kernel hangs during boot (debian sid/unstable)



Here's my issue--

So I had to re-install my system today (long story). 
I run a custom kernel in order to get NVIDIA drivers
to work (the gcc version mismatches always have
stumped me w/regard to getting the drivers working
with stock kernels).

To make a custom kernel, I did the following (all
running sid/unstable:
1.)got the kernel configuration file for the package
kernel-image-2.4.22-686-smp from /boot.

2.)Installed the kernel source for same kernel
(2.4.22) and used the config file from the stock .deb
as the .config in the kernel source tree

3.) after a "make menuconfig oldconfig", where I
simply exited and saved, I ran: make dep; make-kpkg
clean; make-kpkg --append-to-version=.311003
--revision=1 --initrd kernel-image modules-image

4.) installed the resulting deb w/dpkg, ran lilo, and
rebooted

After rebooting, the system always hangs w/the custom
kernel at the line "INIT: version 2.8...".  This is
not because it can't find the hard drive (that was the
problem before doing --initrd with make-kpkg).

Further, the stock kernel runs fine (only problem is
installing the nvidia drivers, which result in
non-loading modules with the stock kernel and
gcc-3.2.2), and was compiled with gcc 3.2.2.  I used
the config file from the stock kernel deb and am using
gcc 3.2.2 (the current version in sid, the machine was
installed earlier today, the 31st of Oct.)

Any input would be appreciated.  Also, if someone can
point out how to get the NVIDIA stuff working with the
stock kernel, that would be another good solution.

Thanks,

Kevin 

=====
Kevin Thornton
Committee on Genetics
University of Chicago
http://www.molpopgen.org

__________________________________
Do you Yahoo!?
Exclusive Video Premiere - Britney Spears
http://launch.yahoo.com/promos/britneyspears/



Reply to: