[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Problem with libartsc.so.0, KDE3.1 on Woody


I followed the method given on the list to get KDE3.1 on a woody stable yesterday
(added "deb ftp://ftp.kde.org/pub/kde/stable/latest/Debian woody main" to
apt-source file , ran apt-get update, then apt-get upgrade, then installed
what I need: Quanta)

KDE (at least Quanta) is working properly but I have a problem with media player (compiled from sources):
Here is what I get when I try to launch it:

mplayer: error while loading shared libraries: libartsc.so.0: cannot open shared object file: No such file or directory

I looked for libartsc.so.0 and found it:

# apt-file search libartsc.so.0

When I try to install libarts or libarts-alsa, here is what I get:

# apt-get install libarts --simulate
Reading Package Lists... Done
Building Dependency Tree... Done
The following packages will be REMOVED:
  kdelibs-bin kdelibs4 libarts1 quanta 
The following NEW packages will be installed:
0 packages upgraded, 1 newly installed, 4 to remove and 1  not upgraded.
Remv quanta (1:3.1.3-0woody1 ftp.kde.org)
Remv kdelibs-bin (4:3.1.3-0woody1 ftp.kde.org) [kdelibs4 ]
Remv kdelibs4 (4:3.1.3-0woody1 ftp.kde.org)
Remv libarts1 (1.1.3-0woody1 ftp.kde.org)
Inst libarts (4:2.2.2-13.woody.8 Debian-Security:3.0/stable)
Conf libarts (4:2.2.2-13.woody.8 Debian-Security:3.0/stable)

Any idea to get this lib without removing KDE (I just need Quanta from KDE) ?

This is not critical because I use VLC for watching videos, still it could be
more annoying if others softs don't work anymore.

Thanks for any advice.

Reply to: