[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

jpilot + serial palm + usb port/cable

Hi everyone,

just inherited an old palm from a friend and am trying to figure out
how to sync it with my debian dmachine (mostly sid).  Installed
jpilot, jpilot-sync, pilot-link; jpilot seems to run ithout
difficulties, but I can't figure out how to sync.  I have an older
palm with a serial port, but my computer has no serial connections on
the mainboard, so I use a serial --> usb cable and connect through a
usb port.  This has worked fine for me on both windoze and mac, so I
think the hardware is ok.  The problem seems to be that the device
jpilot uses to search for my palm is not set properly.  Here's the
error message:

J-Pilot: sync PID = 27400
J-Pilot: press the hotsync button on the cradle or "kill 27400"
pi_bind: No such device
pi_bind Illegal seek
Check your serial port and settings
Exiting with status SYNC_ERROR_BIND

i tried reseting the device using dpkg-reconfigure jpilot, as
suggested in the README.debian file, and set the device to ttyusb0 and
later, to ttyusb1.  Neither seemed to work, and both created links of
the following form:

ll /dev/pilot
lrwxrwxrwx    1 root     root            7 2003-08-19 14:35 /dev/pilot -> ttyUSB1

ll /dev/ttyUSB1
crw-rw-rw-    1 root     dialout  188,   1 2002-03-14 16:54 /dev/ttyUSB1

which looks ok to me, do others agree?  What would folks suggest I do
to fix the problem?  

Thanks for your help,


Reply to: