[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: post-installation script errors

On Mon, Aug 11, 2003 at 10:16:42PM -0700, Peter Nome wrote:
> On a woody base install, I'm getting lots of post-installation script errors, like this:
> # dpkg -i sed_3.02-8_i386.deb
> (Reading database ... 6623 files and directories currently installed.)
> Preparing to replace sed 3.02-8 (using sed_3.02-8_i386.deb) ...
> /var/lib/dpkg/info/sed.prerm: line 9:   653 Segmentation fault      install-info --quiet --remove sed
> dpkg: warning - old pre-removal script returned error exit status 139
> dpkg - trying script from the new package instead ...
> dpkg: ... it looks like that went OK.
> Unpacking replacement sed ...
> Setting up sed (3.02-8) ...
> /var/lib/dpkg/info/sed.postinst: line 11:   662 Segmentation fault      install-info --quiet --section "General commands" "General commands" /usr/share/info/sed.info
> dpkg: error processing sed (--install):
>  subprocess post-installation script returned error exit status 139
> Errors were encountered while processing:
>  sed
> If I comment out the line starting "install-info" in
> /var/lib/dpkg/info/sed.postinst I can complete the configuration with
> apt-get --reinstall install sed (or sometimes dpkg --configure sed).
> However, I get this on lots of packages. What's going on? 

You aren't trying to run with perl 5.8, are you? That's going to be
difficult on woody. See http://bugs.debian.org/159756.


Colin Watson                                  [cjwatson@flatline.org.uk]

Reply to: