[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Odd ethernet problem

I have a weird ethernet problem.

I'm trying to do a netinst of Woody on this other machine I have, but
it absolutely won't find the network. I know this machine has a
Netgear card in it, and tulip is the module to use for that, so I
loaded that during the appropriate step in the installation, but it
can't get any DHCP info. I switched over to the messages console and I
saw a lot of "Network down" errors there.

Of course I tried configuring the interface myself, through the
installer, and I had the same problem.

So I tried booting the machine from my Knoppix CD (how does everyone
feel about Knoppix?). Sure enough, Knoppix got EVERYTHING working, so
I popped into a Konsole and did an ifconfig. The network interface was
called eth1... How does that happen? I thought the first one was 0. I
did an lsmod, also, to make sure about my driver selection and sure
enough, tulip was loaded and being used.

Okay, I figured, maybe there's something strange here I don't
understand, so I went back to the netinst installer and tried bringing
up eth1 myself, but it said the device doesn't exist.

Two questions:

1. Has anyone had this sort of problem and know what I could do?
2. What other things should I do in the working Knoppix system to
   figure out how to get it to work in the installer?

A netinst is kind of hard without the network ;-)


Aaron Bieber
Graphic Design // Web Design

Reply to: