[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Compiling flphoto

Hi all,

I am trying to compile flphoto 1.0 and have installed libfltk1.1-dev
from testing. When I run ./configure, I do not get any error messages.
But when I type make, I get the following:

mas@brahman:~/software/tmp/flphoto-1.0$ make
Compiling Fl_CRW_Image.cxx...
In file included from Fl_CRW_Image.cxx:33:
Fl_CRW_Image.H:34: ANSI C++ forbids declaration `ushort' with no type
Fl_CRW_Image.H:34: parse error before `['
Fl_CRW_Image.H:67: syntax error before `*'
Fl_CRW_Image.cxx: In method `void Fl_CRW_Image::load_image(FILE *)':
Fl_CRW_Image.cxx:118: `image' undeclared (first use this function)
Fl_CRW_Image.cxx:118: (Each undeclared identifier is reported only once
Fl_CRW_Image.cxx:118: for each function it appears in.)
Fl_CRW_Image.cxx:118: parse error before `['
Fl_CRW_Image.cxx: In method `void Fl_CRW_Image::subtract_black()':
Fl_CRW_Image.cxx:939: warning: `int * img' might be used uninitialized in this function
Fl_CRW_Image.cxx: In method `void Fl_CRW_Image::dillon_interpolate()':
Fl_CRW_Image.cxx:1009: `ushort4' undeclared (first use this function)
Fl_CRW_Image.cxx:1009: `oimage' undeclared (first use this function)
Fl_CRW_Image.cxx:1012: parse error before `['
Fl_CRW_Image.cxx: In method `void Fl_CRW_Image::first_interpolate()':
Fl_CRW_Image.cxx:1060: warning: `int val' might be used uninitialized in this function
Fl_CRW_Image.cxx: In method `void Fl_CRW_Image::second_interpolate()':
Fl_CRW_Image.cxx:1092: `last' undeclared (first use this function)
Fl_CRW_Image.cxx:1093: `current' undeclared (first use this function)
Fl_CRW_Image.cxx:1098: parse error before `['
Fl_CRW_Image.cxx:1099: parse error before `['
Fl_CRW_Image.cxx:1129: parse error before `)'
Fl_CRW_Image.cxx: At top level:
Fl_CRW_Image.cxx:1142: new declaration `ushort Fl_CRW_Image::fget2(FILE *)'
Fl_CRW_Image.H:84: ambiguates old declaration `int Fl_CRW_Image::fget2(FILE *)'
Fl_CRW_Image.cxx:1526: type specifier omitted for parameter
Fl_CRW_Image.cxx:1526: parse error before `)'
Fl_CRW_Image.cxx:1527: prototype for `void Fl_CRW_Image::get_rgb(...)' does not match any in class `Fl_CRW_Image'
Fl_CRW_Image.H:90: candidate is: void Fl_CRW_Image::get_rgb(float *, int *)
Fl_CRW_Image.cxx: In method `void Fl_CRW_Image::get_rgb(...)':
Fl_CRW_Image.cxx:1530: `rgb' undeclared (first use this function)
make: *** [Fl_CRW_Image.o] Error 1

Suspecting a version problem, I tried it with both gcc/g++ 2.95/3.2/3.3.
All of them fail identically. Has anybody compiled it? If so, can they
post some pointers to get this application compiled.

I have mailed the upstream author about this. Am not sure when he finds
time to reply. But, I will wait.


Sridhar M.A.

You've been telling me to relax all the way here, and now you're telling
me just to be myself?
		-- The Return of the Secaucus Seven

Reply to: