[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: No space left on device

Hello Salman!

At Sunday 20 July 2003 03:20 Salman Haq wrote:

>  Thanks everybody for your helpful responses. To make some temporary
>  room
> I cleaned up some logs and unnecessary directories in a few of the
> home directories of some of the users.
>  Then I resolved to fix the problem once and for all by using parted
>  to
> resize the partitions. When I finally got around to doing it this
> past weekend, things didn't go as smoothly as I thought they would.
>  When I boot the system using the parted boot disk and started
>  parted I
> saw the following warning message:
> Using /dev/hda
> attempt to access beyond end of device
> 03:00: rw=0, want=58593752, limit=58593750
> Information: The operating system thinks the geometry on /dev/hda is
> 7294/255/63. Therefore, cylinder 1024 ends at 8032.499M
> This is the information that parted shows about my partitions:
> Disk geometry for /dev/hda: 0.000-57220.458 megabytes
> Disk lable type: msdos
> Minor Start           End     Type    Filesystem      Flags
> 1     0.031           31.376  primary fat 16
> 2      31.377      15390.395  primary ntfs            boot
> 3   15390.396        15868.894  primary ext2
> 4   15868.894        54493.923  extended
> 5   15868.925        54015.424  logical ext2
> 6   54015.456        54390.396  logical linux-swap
> Since my original problem requires me to shrink hda5 down to ~10
> gigs and expand hda3 to ~30 gigs I set about to do the following:
> (parted) resize 5 40869.024 54015.424
> and saw this:
> attempt to access ... of device
> 03:00: rw-=0, ... limit=58593750   <-(same error msg as before)
> Warning: You requested to resize the partition to
> 40869.024-54015.424Mb. The closest Parted can manage is
> 15868.925-54015.424. Ok/Cancel? c

A short quote from the GNU parted manual[1]:
| (parted) resize partition_number new start new end
| new start must be the same as the old start for ext2 partitions
| (unfortunately)

So shrinking the partition this way is not possible using parted.

> So parted doesn't want to resize the partition that way. Then I quit
> parted and restarted it as "parted /dev/hda5" and typed:
> (parted) resize 1 0.000 13146.4
>  That actually resized something... when I restarted my computer
>  normally,
> /dev/hda5 mounted to /usr and "df" showed its size as 12 gigs (as
> opposed to the old 37 gigs). However, parted continues to show the
> original numbers. Morever, I still haven't solved my original
> problem, which is expanding /dev/hda3. When I try:
> (parted) resize 3 15390.393 40000.000
> it says "The closest parted can manage is 15390.393 15868.894"

The partition has to be in one contigeous block, that's why your
attempt didn't work out.

>  I also tried "parted /dev/hda4" but that just says "can't partition
> outside of disk" even if I simply try to print info.
>  What do I have to do to get rid of that disk access error and
> shrink hda5 (or hda4,5,6) and expand hda3?
>  In the meanwhile, I have 'resized' hda5 back to its original size
> so that 'df' show its size as 37 gigs. I hope this makes sense.

There is an example repartitioning scheme in the GNU parted manual[1].
It doesn't completely apply to you, but it might be of some help; I
guess you can work out the needed additions.
Referring to your type of problem they say:
| So this process is going to be rather complicated. It is possible,
| though.

Don't give up... ;)



Reply to: