[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Debian Installation- difficulties configuring system and installing packages



Hello,

I am installing Debian Woody on my second hard-drive, using my existing system to install. Completed to the point of installing dbootstrap,

(following the instructions outlined in "Installing Debian GNU/Linux 3.0 for Intel x86", specifically, "Installing Debian GNU/Linux from a Unix/Linux system" http://www.debian.org/releases/stable/i386/ch-preparing.en.html#s-linux-upgrade)

everything seems OK to this point.

NOW, I am trying to install some packages so as to configure the system and install the kernel - this is where I am running into trouble. I will outline my steps as follows (after where the difficulties began):

3.7.5.3 Configure Networking:

cannot find /etc/network/interfaces (cannot even find /etc/network)

cannot find /usr/share/doc/ifupdown

3.7.5.4 Configure Timezone, Users and APT

base-config not installed

3.7.5.5 Configure Locales

apt-get not installed

This is where I started trying to use dpkg to install these packages.

I tried installing apt and base-config using dpkg, got an incomplete install. Ran dpkg to install some of the dependencies it complained about, but got more complaints. Ran dpkg -C, showing that apt and apt-utils are not completely installed. It suggested running dpkg --congifure, but that didn't help.

Ran apt-get anyway, on apt, glibc, and some other dependencies, and got more complaints, saying basically the same thing as dpkg.

Seem to get a lot of circular dependencies that won't resolve.

So I've got stuff that is not configured, partially installed, etc.

I even ran dselect accepting all the default selections and still get the same complaints basically. I thought maybe that if it just "stuck them in there all at once", they'd know what to do. (I really don't want to do the installation this way, however. I would like learn about Linux, and not just press the magic buttons)

Some of the messages I wonder about are:

dpkg not recorded as installed, cannot check for epoch support !

If dpkg is not installed, why am I able to use it, and also it does not come up as partially installed when running dpkg -C?

If apt and apt-utils are not completely installed (according to dpkg -C) why am I able to use apt-get?

Another message:

warning: Setting locale failed.</ br>
perl: warning: Please check that your locale settings:
<blockquote> LANGUAGE = (unset),</ br>
LC_ALL = (unset),
LANG = "en_US.UTF-8"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").

Could that have anything to do with it?
Frankly, I don't really understand the locale setting thing, or the locales.conf file. My searches on the net regarding that have been fruitless. Perhaps that is another topic though.

I have included some of the output below, which reflects about all of the complaints I am getting.

Thank you for listening to my problem.

Allasso Travesser


BEGIN OUTPUT MESSAGES:

dpkg -i apt....(etc)

(Reading database ... 96 files and directories currently installed.)
Preparing to replace apt 0.5.4 (using .../binary-i386/apt_0.5.4_i386.deb) ...
Unpacking replacement apt ...
dpkg: dependency problems prevent configuration of apt:
apt depends on libc6 (>= 2.2.3-7); however:
Package libc6 is not installed.
apt depends on libstdc++2.10-glibc2.2; however:
Package libstdc++2.10-glibc2.2 is not installed.
dpkg: error processing apt (--install):
dependency problems - leaving unconfigured
Errors were encountered while processing:
apt

dpkg --configure apt

dpkg: dependency problems prevent configuration of apt:
apt depends on libc6 (>= 2.2.3-7); however:
Package libc6 is not installed.
apt depends on libstdc++2.10-glibc2.2; however:
Package libstdc++2.10-glibc2.2 is not installed.
dpkg: error processing apt (--configure):
dependency problems - leaving unconfigured
Errors were encountered while processing:
apt

dpkg -C

The following packages have been unpacked but not yet configured.
They must be configured using dpkg --configure or the configure
menu option in dselect for them to work:
apt Advanced front-end for dpkg
apt-utils APT utility programs


apt-get install apt

Reading Package Lists...
Building Dependency Tree...
Sorry, apt is already the newest version.
You might want to run `apt-get -f install' to correct these:
Sorry, but the following packages have unmet dependencies:
apt: Depends: libc6 (>= 2.2.3-7) but it is not going to be installed
Depends: libstdc++2.10-glibc2.2 but it is not going to be installed
apt-utils: Depends: libc6 (>= 2.2.3-7) but it is not going to be installed
Depends: libdb2 (>= 2:2.7.7-4) but it is not going to be installed
Depends: libstdc++2.10-glibc2.2 but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

apt-get install libc6

Reading Package Lists...
Building Dependency Tree...
You might want to run `apt-get -f install' to correct these:
Sorry, but the following packages have unmet dependencies:
apt: Depends: libstdc++2.10-glibc2.2 but it is not going to be installed
apt-utils: Depends: libdb2 (>= 2:2.7.7-4) but it is not going to be installed
Depends: libstdc++2.10-glibc2.2 but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

apt-get -f install

Reading Package Lists...
Building Dependency Tree...
Correcting dependencies... Done
The following extra packages will be installed:
libc6 libdb2 libstdc++2.10-glibc2.2
The following NEW packages will be installed:
libc6 libdb2 libstdc++2.10-glibc2.2
0 packages upgraded, 3 newly installed, 0 to remove and 0 not upgraded.
2 packages not fully installed or removed.
Need to get 0B/3790kB of archives. After unpacking 14.0MB will be used.
Do you want to continue? [Y/n]
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = (unset),
LC_ALL = (unset),
LANG = "en_US.UTF-8"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
(Reading database ... 96 files and directories currently installed.)
Unpacking libc6 (from .../libc6_2.2.5-11.5_i386.deb) ...
dpkg not recorded as installed, cannot check for epoch support !
dpkg: error processing /var/cache/apt/archives/libc6_2.2.5-11.5_i386.deb (--unpack):
subprocess pre-installation script returned error exit status 1
Errors were encountered while processing:
/var/cache/apt/archives/libc6_2.2.5-11.5_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)






Reply to: