[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Backporting of debhelper: loops in dependencies !?



I'm in the process of backporting ohpone 1.3.7-2 to woody, but I'm
running into a problem with cyclic dependencies in the debconf area:

oh-phone 1.3.7-2 (=sid) build-depends on libpt-dev (>=1.4.11-3) [source: pwlib]

pwlib 1.4.11-3 (=sid) build-depends on libdv2-dev [source: libdv]
    
libdv 0.99-2 (=sid/sarge) build-depends on debhelper (>= 4.1.1)
        
debhelper 4.1.45 (=sid/sarge) builds OK, then resulting .deb then
depends on debconf-utils (>= 1.1.1) [source: debconf]

debconf 1.2.35 (=sarge) build-depends on debhelper (>= 4.1.27)

So... 
    To backport libdv I need a newer version of debhelper. 
    To install the newer (backported) debhelper I need a newer version of debconf. 
    To backport the new version of debconf I need to install a newer debhelper...

    [This is not an exhaustive list of problems; there may be other
    problems ahead...]

Which makes me wonder: How did debconf/debhelper get into testing/sarge
in the first place?  Somebody must have performed some magic that I
should be able to do too...

Or I have got my facts wrong?  Is there another way? 

Any ideas will be most welcome!

-- 
Karl E. Jørgensen
karl@jorgensen.com   http://karl.jorgensen.com
==== Today's fortune:
Conscience is what hurts when everything else feels so good.

Attachment: pgplvHglfNHqT.pgp
Description: PGP signature


Reply to: