[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Local package repositories

Hi group,

having some problems with a local package repository I tried to set up.
So, I copied my locally created debs to a directory, ran
dpkg-scanpackages (didn't use overridefile) and added this directory to
my sources.list. Yes, it all works, except for the following annoying

If I run apt-get install foo --simulate, I see that apt wants to install
the woody version of package foo, and not the version from my local
repository. If I run apt-get install foo -t bar --simulate, it all works
fine. Of course, 'bar' is not a valid component, but that doesn't matter
to apt. I configured apt to only pull packages from stable, but I
configured my local repository as stable main.

I tried to copy a Release file from
/var/lib/apt/lists/ftp.<snip>.Release. The file is read by apt-get
update and copied to /var/lib/apt/lists, but that doesn't help.

I also removed --simulate to make sure that the package could be
installed. It works (if I add a '-t whatever' to apt-get...)

Anyone seen this before? If not, anyone using local package repositories
and if so, how did you set it up?




deb file:/home/dfokkema/deb-archive/ stable main

deb http://security.debian.org/ stable/updates main
deb ftp://ftp.nl.debian.org/debian/ stable main

Packages are in /home/dfokkema/deb-archive/dists/stable/main/binary-i386

Reply to: