[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: testing: dist-upgrade to perl-5.8 removes modules

On Sat, May 31, 2003 at 06:28:06PM -0700, Randall Hansen wrote:
> I'm running testing, and a week or two ago apt [dist-upgrade] wanted
> to install a new Perl (5.8) to replace my current 5.6.1.  I've no
> special preference for 5.6x, but apt also wants to remove several Perl
> modules on which I depend.
> To wit: Digest::MD5 appears to be replaced with libmd5-perl;
> Test::Harness now appears to be included in perl-modules.  Others,
> though, I haven't been able to verify or find:  Time::HiRes, Storable,
> GD.

Digest::MD5, Time::HiRes, and Storable have been sucked into the perl
package, so it's OK to let the packaging system remove those. GD is in
any of libgd-gd1-perl, libgd-gd1-noxpm-perl, libgd-gd2-perl, or
libgd-gd2-noxpm-perl; libgd-gd2-perl is probably the sensible choice if
you're not sure.


Colin Watson                                  [cjwatson@flatline.org.uk]

Reply to: