[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

been up that long_root is jello


forgive the 'cat' trap <g>

my post/plea is the result of having struggled to set up a Debian
2.4.18 box + now finding i cannot gain admin access using what i
believe to be a correct root PW.

the story goes:
Six weeks ago i set this box up, its a dual boot + dual HDD Win95B
(OSR2) and Debian 2.4 kernel with wmaker and some gnome reliant apps
but no gnome gui loaded. Basicly i have been 'away' from using root for
weeks, i now want to change some settings/permissions.
The root pw was setup deliberately simple (similar to user pw) until i
was familiar with "how it all worked". today i find the 6keystroke PW i issue
will not give me root. there are only so many combinations, i have
spent quite some time exhausting them all.
In the battle to get the box setup i read often on how to reset root
pw, so my thougts turn to getting into /etc passwd or /shadow and
simply changing the XXXX.
I know about booting from the install CD. 
at boot: i issue RESCUE 
boot halts at "Kernel panic: VFS: unable to mount root fs on 01:00 .
I know about booting from the install CD. 
at boot: i issue RET 
boot goes through to "rescue floppy "GUI. 
Instead of _continue_ (which starts a new install) i use Alt+F2 
console appears with # prompt i can
move around the virtual disk set up by the boot but i cannot 'see' my
tree on the HDDs.
I know about issueing init at lilo <linux init=/bin/sh rw> 
the resultant prompt (#) will not accept any commands issued and when 
<mount /mnt /dev/hd* > is issued the error/s returned are
"file/directory not found".
IRC Gurus suggest this is because i am in "Ramdisk mode" <shrug>
I know about starting in single user mode. 
this boots straight to the xdm gui which requires a UID/pw to login.

I have "tomsrtbt tools". booting with this floppy gets me a virtual
console but i am yet to figure *how* to use it. i cannot chroot to my
tree for example, or mount my partitions/directorys. 
the FAQ for this tool is absolutely ph $%^@ing hopeless!

I have RIP rescue tool. so far i have only tried to unpack this, it
failed to find the syslink.com file sitting in its own directory! so i
gave up on that :-(

I have a "guaranteed boot disk" from an 'IRC Guru', it wont copy to a
floppy ("insufficent space")
I have tried copying ../etc/passwd to another directory accessible
from windows. (as a normal user) i get  "permission denied" (understandable as
i had not got around to setting up permissions for users and i doubt i
would have enabled that ability anyway)
I know what to do with ../etc/passwd or ../etc/shadow when i get
access to it. getting access is my problem.
I post all of the above not to say ,, "i have tried this and it dosent
work" but in the hope that seeing what i haqve tried some may see an
error in the method or an alternative method (variation),, or be able to
say "this part of your system is ph^%&#ed !

for what you can
do...thank you.




·´¯`·.¸¸..<º))))><.·´¯`·.¸¸.·´¯`·.¸<º))))><Please *_do n0t_* add my E-mail 
address to any function of address books in:

0utlook Express;Composer;Messenger;AOL;Eudora;CC MAIL

Do you Yahoo!?
Yahoo! Tax Center - File online, calculators, forms, and more

Reply to: