[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

[FIXED] Re: /usr/bin/ld: cannot find -ltcl

On Sun, 16 Mar 2003 at 4:16pm, Eric G. Miller wrote:

:On Sun, Mar 16, 2003 at 06:23:24PM -0500, Patrick Wiseman wrote:
:> Hi, all:
:> I'm trying to compile a program - not mine, I'm not a C programmer - which
:> wants tcl.  At first, it couldn't find tcl.h, but I supplied the full path
:> (I know, that's not really kosher) and it got past that error.  Now, I get
:> the subject error.  In context, it looks so:
:> # make
:> gcc tcldtk.o -ltts -ltts_us -ltcl  -shared -o tcldtk.so
:> /usr/bin/ld: cannot find -ltcl
:> collect2: ld returned 1 exit status
:> make: *** [tcldtk.so] Error 1
:> I have /usr/lib/tcl8.0, 8.0jp, 8.2, 8.3 and tclX8.0.4.  Maybe that's the
:> problem?
:> Any suggestions?
:For the includes:

That didn't help find tcl.h, assuming I put it in the right place, which
was in the command line in the Makefile?  I tried both




added to the command line, and just putting the -I line in the command
line, but neither way did it find tcl.h.  Putting the full path in the
source file did, though, so, inelegantly, the thing compiled.

:For the library:

That worked - thanks!


Patrick Wiseman                               pwiseman@mindspring.com
Linux user #17943                             *Google First, Ask Later*

Reply to: