[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

More apt-problems.



What does this mean? All the dependencies _are_ installed. But why wont
php still install? (Debian/Testin)

scooter:~# apt-get install php4
Reading Package Lists... Done
Building Dependency Tree... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

Sorry, but the following packages have unmet dependencies:
  php4: Depends: libbz2-1.0 but it is not going to be installed
        Depends: libc6 (>= 2.2.4-4) but it is not going to be installed
        Depends: libdb2 (>= 2:2.7.7-4) but it is not going to be
installed
        Depends: libexpat1 (>= 1.95.2-6) but it is not going to be
installed
        Depends: libmm11 but it is not going to be installed
        Depends: libpam0g (>= 0.72-1) but it is not going to be
installed
        Depends: libpcre3 but it is not going to be installed
        Depends: zlib1g (>= 1:1.1.4) but it is not going to be installed
        Depends: apache-common (>= 1.3.23) but it is not going to be
installed
        Depends: fileutils (>= 4.0-5)
E: Sorry, broken packages
scooter:~# dpkg -l | grep libc6
ii  libc6          2.3.1-14       GNU C Library: Shared libraries and
Timezone
ii  libc6-dev      2.3.1-14       GNU C Library: Development Libraries
and Hea
ii  libgpmg1       1.19.6-12      Gene

 




Reply to: