[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

logcheck oddity

I am using stable for a small personal server.  I have postfix 
copying all my incoming Email to a file /var/log/mailcopy/chris.mail
as a belt and braces check I get things and to enable me to use 
hypermail to create a useful archive of it.

I wanted to rotate that file using logcheck and created a file 

"/var/log/mailcopy/chris.mail" {
        rotate 7

That didn't do anything so logged in as root I tried logrotate -d 
chrismail which said the file didn't need rotating.  So I tried 
logrotate -d -f chrismail which said it did everything, all the file 
copying etc. and the creation of the new file ... but it didn't.  
I've tried that several times with same result.

savelog, interestingly, seems to work fine.  /var/log/mailcopy is 
world readable and executable and owned and grouped to root.  
/var/log/mailcopy/chris.mail is owned and grouped to postfixe (my 
user for postfix) and owner and group rw and world r permitted.

I must be looking straight through something, I've read the excellent 
man entry for logrotate backwards and forwards and can't see it and 
logrotate seems to be continuing to do its duty fine by everything it 
should in /var/log

Anyway any ideas?


PSYCTC: Psychotherapy, Psychology, Psychiatry, Counselling
   and Therapeutic Communities; practice, research, 
   teaching and consultancy.
Chris Evans & Jo-anne Carlyle
http://psyctc.org/ Email: chris@psyctc.org

Reply to: