[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: where is libMP3.so



On Thu, Feb 27, 2003 at 08:03:17AM -0600, John Foster wrote:
> Vincent Lefevre wrote:
> 
> >On Wed, Feb 26, 2003 at 14:00:18 +0000, Colin Watson wrote:
> > 
> >
> >>On Wed, Feb 26, 2003 at 02:30:57PM +0100, Vincent Lefevre wrote:
> >>   
> >>
> >>>On Wed, Feb 26, 2003 at 23:18:53 +1100, Rob Weir wrote:
> >>>     
> >>>
> >>>>Debian contains no MP3 encoders due to patent issues,
> >>>>       
> >>>>
> >>>Not even in non-us?
> >>>     
> >>>
> >>The patent is not US-specific.
> >>   
> >>
> >
> >OK, so perhaps one would need another section for countries where
> >software patents are not protected.
> >
> > 
> >
> Actually I located the correct libs on the site below and they are FSF 
> copyrighted according to the files themselves. I have to assume the 
> actual code is not pirated at this point as they are being distributed 
> with the FSF disclaimer included.
> 
> http://members.jcom.home.ne.jp/jacobi/linux/softwares.html#mp3lib

The problem isn't the license of the code, lame and associated stuff is
all GPL or LGPL.  The problem is that the mp3 format (or something, I
forget the details) is patented, and the Fraunhoffer Institute wants
royalties for ever mp3 encoder (and, apparently, player)
distributed/sold.  Obviously this is highly incompatible with Debian's
mission as a Free OS, so Debian can't distribute any mp3 encoder.
Interestingly, Debian does contain an MPEG-1 Audio Layer-2 encoder,
which (I assume) does not make use of any patented algorithms or formats
or whatever.  Of course, the real solution is to switch to Ogg Vorbis :)

> That aside I have compiled and installed them and tried to compile the 
> cvs from mplayer using mplayer-update ( this is distributed as a .deb 
> file by the author and is GPL copyrighted)
> I am still getting the error message indicated in the output snippet below.
> 
> make[3]: Entering directory 
> `/root/.mplayer-update/sources/mplayerxp-20030227/codecs/mp3lib'
> install -D -m 755 -s -p libMP3.so 
> /root/.mplayer-update/sources/mplayerxp-20030227/debian/mplayerxp/usr/bin/libMP3.so
> install: cannot stat `libMP3.so': No such file or directory
> make[3]: *** [install] Error 1
> make[3]: Leaving directory 
> `/root/.mplayer-update/sources/mplayerxp-20030227/codecs/mp3lib'
> make[2]: *** [install] Error 2
> make[2]: Leaving directory 
> `/root/.mplayer-update/sources/mplayerxp-20030227/codecs'
> make[1]: *** [install] Error 2
> make[1]: Leaving directory 
> `/root/.mplayer-update/sources/mplayerxp-20030227'
> make: *** [install] Error 2
> debuild: fatal error at line 456:
> dpkg-buildpackage failed!
> ko : returned value 29
> 
> 
> The experiences of  anyone who has been successful in getting this or 
> something similar to compile are VERY welcome. I do not very often have 
> to venture outside of debian to meet my needs and this is well outside 
> my range of experienc.
> Thanks!

It sure looks like you haven't got libMP3 installed the way mplayer
expects it to be.  Have you tried getting liblame0 from Christian's site
(I gave the URL earlier)?  I'm fairly sure it contains libMP3, and it
should Just Work.  If you really want to compile it for optimisations or
whatever, get the source package from Christian's site and rebuild it
locally, modifying CFLAGS as appropriate.

-- 
Rob Weir <rweir@ertius.org>				http://ertius.org/

Attachment: pgp2XfVRWQUuB.pgp
Description: PGP signature


Reply to: