[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Request confirmation this is a dpkg bug

Hello everyone,

I've been having some trouble with dpkg and afaik it is a bug.

Can someone confirm this is worth a bugreport ?

Sometimes (not all packages, not always) dpkg fails as follows:
dpkg: error processing
/var/cache/apt/archives/noatun-plugins_4%3a3.1.0-2_i386.deb (--unpack):
 failed to realloc for variable buffer: Cannot allocate memory

Searching the archive reveals this bug has already been reported 2 years
ago (#85040) and was apparantly solved ... so it shouldn't be happening
on this version of dpkg.

dpkg:     1.10.9 (i386) (same result with version 1.9.21 (i386))
dselect:  1.10.9
libc6:    2.3.1-11 
debian:   stable/testing/unstable
kernel:   2.4.19 
arch:     i686 (duron 1000Mhz)
ram:      512MB
(Since some bugs with dpkg had to do with locales I checked that it does
happen with LC_ALL=C and LANG=C)

Is this a bug ? If so, should I reopen the original #85040 ? (Is that
even possible ?) 
Please be gentle since I am not an expert and have never submitted a


PS: I am aware of the existence of the *reportbug* package.

                Linux is only free if your time has no value...

Reply to: