[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Transfering my system to a new disk (was: Root partition stuck in read-only mode.)

Quoting Nathan E Norman <nnorman@incanus.net>:

> [ ... ]
> Gack!
> How old is the drive?  Any chance the issue is termination or a
> misconfigured jumper?  You're using an Adaptec 2940?

I'll check the jumper later, when I open up my box.  Yes, I believe
it's a 2940

> [ ... ]
> Lloyd Zusman <ljz@asfast.com> writes:
> > Thanks again for the earlier help, and thanks in advance for any
> > help you might be able to offer for this new system-copy task.
> This may prove difficult.  Why not just remove /dev/sda once you've
> copied stuff over?  Then, if you run LILO boot wiuth a rescue floppy
> and/or CD, type "linux root=/dev/sda1" at the prompt, and rerun lilo
> once you're up.
> If you use GRUB, it would be a good idea to make a grub boot floppy;
> then you can boot to any kernel on any drive in the system!  Google
> for this or ask me; I'll look around for my link.

Well, I'm using LILO.  I want to create a proper rescue disk,
and I used the mkboot utility to do so.  It told me that it created
a proper disk, but when I tried to boot off of it, I got a kernel
panic with a message that stated that there was not a proper
root file system.  I did the boot by typing "linux" and also
"linux root=/dev/sda2".  Both resulted in the same error.

I don't know if this matters, but there are no /boot/boot*.b
files on my system.  The mkboot utility seems to be looking for
a /boot/boot.b file, although it doesn't give me an error.  But
is that a problem?

> [ ... ]
> --
> Nathan Norman - Incanus Networking mailto:nnorman@incanus.net
>   prepBut nI vrbLike adjHungarian! qWhat's artThe adjBig nProblem?
>           -- alec flett @netscape

 Lloyd Zusman
 God bless you.

Reply to: