[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

OT: sometimes it's good to see the competition

I've run a lot of linux and unix versions over the years.. last year
I took a liking to SuSE, it has a lot of bells and whistles. My first
real experience with it was 7.3, very impressive. So I ordered 2 copies
of 7.3 pro (~$140). Then 8.0 came out ..a bit after that I ordered 2
copies of that(another ~$140). More recently 8.1 came out, this time
I only got 1 copy(~$66). (Originally I bought 2 copies so my sister
would have a copy of the manuals for her system)

I don't mind paying, its a fancy distro, but I find it difficult to
understand why such basic, important things slip past their QA teams.
When 8.0 came out they had a bug where if you launched YOU(YaST Online
update, their auto update tool) when logged in as root it would
fail to verify gpg signatures forcing you to click a dialog box maybe
50 times(no way to abort mid-update, I tried once by killing the process,
which caused the online update tool to immediately crash when launched
every time after that,ended up having to reinstall the whole box, all
attempts to purge and reinstall the YaST2 subsystem failed to resolve the
issue and the box was only 2 hours old so it wasn't a big loss). But if you
logged in as a normal user and loaded it(which it then prompted for the root
password) it
worked fine. Ok..what a pain, I figure it will be fixed in the next

And it was, but in the process they introduced a new "bug" into YOU,
it uses wget to download stuff apparently, and they failed to
configure wget to use passive ftp, so any attempts to download fail(if
your behind some form of NAT). I didn't know at the time, so I configured
SuSE to use a proxy using their YaST2 tool, but I guess that setting doesn't
affect YOU since wget's config wasn't changed. Only later did I see on their
support page that they forgot to turn on passive ftp. When running YOU
it just spits back a generic message saying basically 'error, try another

With all the bells and whistles I would of hoped this very very
important application would work nearly flawless(infact it did, in
it's first incarnation!). dissapointing. While SuSE has neat stuff
like built in RAID/LVM support in the installer, I think having a working
update tool is more important. Especially if this tool is designed
from the ground up by SuSE, it's not some port of apt-get from
some unsupported 3rd party[1], or some other tool, SuSE made it, why
doesn't it work!(out of the box)

and why they don't default to using HTTP vs FTP I'm not sure(their
list of update servers doesn't list a single HTTP server). And why
their proxy config doesn't change wget..*sigh* Also their mirror
system is real shitty. Recently I installed SuSE 8.0 on about 6 differnet
systems, when running YOU I had to connect to usually 2 or 3 different
mirrors, since all of them were missing at least 1 package, and there
was 1 package(forget which) which wasn't on ANY of the mirrors even the
main SuSE site. If they aren't gonna provide the package, yank it so
the update tool doesn't try to look for it!

I still like SuSE, but I don't see it replacing any of my debian systems.

And it would be nice if I didn't have to buy a CD to upgrade minor
revisions(should be provided via YOU but I think YOU is not robust enough
to handle such an upgrade).


[1] I had tried apt-get which was ported to SuSE back about 7-8 months
ago? on SuSE 8, it downloaded a buncha stuff then spit out an obscure
error which I was unable to resolve(and it refused to continue).

Reply to: