[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Upgrade 3.0beta->3.0r0->3.0r1 with buggy behaviour ?



Hello, dear Debian-interested community,

with 

apt-cdrom add
apt-get update
apt-get upgrade

I upgraded 3.0 beta up to 3.0 r0 with the conplete CD-Set,
without any failures.

So, I did the the same game with the oficial Update-CD, downloaded from
ftp://ftp.de.debian.org/debian-cd/images/3.0_r1/i386/
upgrading 3.0 r0 to 3.0 r1.

And by the way, there unfortunately began the desaster on my system:

Reading Package Lists...
Building Dependency Tree...
The following packages have been kept back
  a2ps adduser apt aptitude at autoclass ...
...   ... xterm xvfb zlib1g 
1 packages upgraded, 0 newly installed, 0 to remove and 279 not upgraded.
Sorry, but the following packages have unmet dependencies:
  communicator: Depends: communicator-smotif-473 but 4.73-18 is to be installed
                Depends: netscape-java-473 but 4.73-18 is to be installed
                Conflicts: netscape-base-407 but it is not installable
                Conflicts: netscape-base-408 but it is not installable
                Conflicts: netscape-base-45 but it is not installable
                Conflicts: netscape-base-451 but it is not installable
                Conflicts: netscape-base-46 but it is not installable
                Conflicts: netscape-base-472 but it is not installable
  communicator-smotif-473: Depends: libstdc++2.9-glibc2.1 but 2.91.66-4 is to be installed
                           Depends: libxpm4
                           Depends: communicator-base-473 but 4.73-18 is to be installed
                           Depends: netscape-base-4 (>= 1:4.72-24) but 1:4.77-2 is to be installed
                           Conflicts: communicator-smotif-473-libc5 but it is not installable
  gdm: Depends: xlib6g (>= 3.3.6) but 3.3.6-11potato32 is to be installed
       Depends: libpam-modules (>= 0.72-1) but 0.72-9 is to be installed
  libnspr3: Conflicts: libnspr20 but it is not installable
  libssl09: Conflicts: ssleay (< 0.9.2b) but it is not going to be installed
  mozilla: Depends: libstdc++2.10 but 1:2.95.2-14 is to be installed
           Depends: libnspr3 (>= M14) but M14-2 is to be installed
  ssh: Depends: libz1
       Conflicts: ssh-nonfree but it is not going to be installed
  task-gnome-apps: Depends: gnome-audio but 1.4.0-4 is to be installed
                   Depends: gnome-admin but 1.0.3-2 is to be installed
                   Depends: gnotes but 1.74 is to be installed
  xaw3dg: Depends: libc6 (>= 2.1.2) but 2.1.3-20 is to be installed
          Conflicts: axe (< 6.1.2-2) but it is not going to be installed
  xext: Depends: libc6 (>= 2.1.2) but 2.1.3-20 is to be installed
  xf86setup: Depends: tk8.2 (>= 8.2.2) but 8.2.3-4 is to be installed
  xmanpages: Conflicts: xman but it is not installable
  xprt: Depends: libc6 (>= 2.1.2) but 2.1.3-20 is to be installed
  xserver-vga16: Depends: libc6 (>= 2.1.2) but 2.1.3-20 is to be installed


The /etc/apt/sources.list:

# standard
deb cdrom:[Debian GNU/Linux 3.0r1 Update CD 20030109: i386]/ woody contrib main non-US/contrib non-US/main non-US/non-free non-free
deb cdrom:[Debian GNU/Linux 3.0 r0 _Woody_ - Official i386 Binary-7 (20020718)]/ unstable contrib main non-US/contrib non-US/main
deb cdrom:[Debian GNU/Linux 3.0 r0 _Woody_ - Official i386 Binary-6 (20020718)]/ unstable contrib main non-US/contrib non-US/main
deb cdrom:[Debian GNU/Linux 3.0 r0 _Woody_ - Official i386 Binary-5 (20020718)]/ unstable contrib main non-US/contrib non-US/main
deb cdrom:[Debian GNU/Linux 3.0 r0 _Woody_ - Official i386 Binary-4 (20020718)]/ unstable contrib main non-US/contrib non-US/main
deb cdrom:[Debian GNU/Linux 3.0 r0 _Woody_ - Official i386 Binary-3 (20020718)]/ unstable contrib main non-US/contrib non-US/main
deb cdrom:[Debian GNU/Linux 3.0 r0 _Woody_ - Official i386 Binary-2 (20020718)]/ unstable contrib main non-US/contrib non-US/main
deb cdrom:[Debian GNU/Linux 3.0 r0 _Woody_ - Official i386 Binary-1 (20020718)]/ unstable contrib main non-US/contrib non-US/main
deb cdrom:[Debian GNU/Linux 3.0 beta _Woody_ - fsn.hu unofficial i386 Binary-8 (20020514)]/ unstable contrib main non-US/contrib non-US/main non-US/non-free non-free
deb cdrom:[Debian GNU/Linux 3.0 beta _Woody_ - fsn.hu unofficial i386 Binary-7 (20020514)]/ unstable contrib main non-US/contrib non-US/main non-US/non-free non-free
deb cdrom:[Debian GNU/Linux 3.0 beta _Woody_ - fsn.hu unofficial i386 Binary-6 (20020514)]/ unstable contrib main non-US/contrib non-US/main non-US/non-free non-free
deb cdrom:[Debian GNU/Linux 3.0 beta _Woody_ - fsn.hu unofficial i386 Binary-5 (20020514)]/ unstable contrib main non-US/contrib non-US/main non-US/non-free non-free
deb cdrom:[Debian GNU/Linux 3.0 beta _Woody_ - fsn.hu unofficial i386 Binary-4 (20020514)]/ unstable contrib main non-US/contrib non-US/main non-US/non-free non-free
deb cdrom:[Debian GNU/Linux 3.0 beta _Woody_ - fsn.hu unofficial i386 Binary-3 (20020514)]/ unstable contrib main non-US/contrib non-US/main non-US/non-free non-free
deb cdrom:[Debian GNU/Linux 3.0 beta _Woody_ - fsn.hu unofficial i386 Binary-2 (20020514)]/ unstable contrib main non-US/contrib non-US/main non-US/non-free non-free
deb cdrom:[Debian GNU/Linux 3.0 beta _Woody_ - fsn.hu unofficial i386 Binary-1 (20020514)]/ unstable contrib main non-US/contrib non-US/main non-US/non-free non-free
deb cdrom:[Debian GNU/Linux 2.2 r6 _Potato_ - Official i386 Binary-3 (20020405)]/ unstable contrib main non-US/contrib non-US/main
deb cdrom:[Debian GNU/Linux 2.2 r6 _Potato_ - Official i386 Binary-2 (20020405)]/ unstable contrib main non-US/contrib non-US/main
deb cdrom:[Debian GNU/Linux 2.2 r6 _Potato_ - Official i386 Binary-1 (20020405)]/ unstable contrib main non-US/contrib non-US/main

In this condition, the system is unable to use 
dselect for installing any desired packets :-(.

After that, I tried apt-get dist-upgrade.

...and there the following messages:

The following packages have been kept back
  balsa gedit gnome-panel gnome-panel-data gnome-session gnome-utils gnumeric
  tetex-bin
270 packages upgraded, 103 newly installed, 9 to remove and 8 not upgraded.
Need to get 0B/177MB of archives. After unpacking 139MB will be used.
Do you want to continue? [Y/n] Y
Media Change: Please insert the disc labeled 'Debian GNU/Linux 3.0r1 Update CD 20030109: i386' in the drive '/cdrom/' and press enter

...Yeaaah, but there is existing only this _ONE_ 3.0r0-Upddate CD, including
all packets with changes (3.0r0 -> r1) !?

.... now, I inserted this CD and pressed <ENTER>.

The system answered:

E: Internal Error, Could not perform immediate configuration

...Whow, that's a fine result of this progressive Debian packet-mechanism !? #-]

Did you experience the same "adventure" like me ?
Please, can you tell me, what's wrong here and what I've to do,
to obtain a properly upgraded 3.0r1 from this _ONE_ Updating-CD ? 

Many thanks,
good Debianing ;-)
and sincerely

Christoph Walther



Reply to: