[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: cups foomatic problem - New Problem

On Wed, Jan 22, 2003 at 10:23:56AM -0500, Thomas H. George,,, wrote:
As yet no help on the old problem.  In the meantime:

I have a third box in which I just installed Woody from the CD set,
went on line (DSL) an ran dist-upgrade, then configured a 2.4.18 kernel,
used apt-get to install cupsys, cupsomatic-ppd and foomatic-bin.  This
box has an HP Deskjet 940c on /dev/lp0.  The above packages did not
include a driver for the 940c so I downloaded two versions (old and new
cups format) from www.linuxprinting.org - neither works!

I installed and tested these drivers from localhost:631 as lpadmin and
lpstat are unknown on the system!??  lpinfo works.

I really would appreciate some help with these problems.

Tom George

> My system is Debian Testing with a 2.4.20 kernel.  An Epson Stylus Color 
> printer is on usblp0.
> I used apt-get install to install cupsys, cupsomatic-ppd and 
> foomatic-bin.  Three drivers were listed for the printer.  I tried each 
> in turn with the commands
>    lpadmin -p lp -E -v usb:/dev/usblp0 -m "one of the 860 drivers"
>    lp testtext
> In all three cases nothing was printed.  The attachment is a segment of 
> error_log.
> Background:  A year ago I purchased the CUPS Manual with CD.  The 
> printer worked perfectly with the CD software.  Recently I installed 
> KDE.  The printer worked from the terminals but not from KDE.  Then I 
> installed the Debian packages as described above.  The printer no longer 
> responds even to the command line.
> I have a second system running Debian Woody with a 2.4.18 kernel and a 
> Brother HL-730 laser printer on /dev/lp0.  When I installed the Debian 
> releases on this system everything work immediately.  I can print from 
> the command line, from the KDE Printing Manager test and from Star Office.
> I would appreciate any suggestions to get the testing system running.

> D [22/Jan/2003:08:16:59 -0500] foomatic-gswrapper: gs '@stc740pl.upp' '-dBATCH' '-dSAFER' '-dQUIET' '-dNOPAUSE' '-sOutputFile=/dev/fd/3' '/dev/fd/0' 3>&1 1>&2
> D [22/Jan/2003:08:16:59 -0500] Unable to open command line file stc740pl.upp
> D [22/Jan/2003:08:16:59 -0500] Couldn't exec foomatic-gswrapper @stc740pl.upp -q -dBATCH -dSAFER -dQUIET -dNOPAUSE  -sOutputFile=- - at /usr/lib/cups/filter/cupsomatic line 1018.
> D [22/Jan/2003:08:16:59 -0500] tail process done writing data to *main::STDOUT
> D [22/Jan/2003:08:16:59 -0500] KID4 finished
> D [22/Jan/2003:08:16:59 -0500] Main process finished
> D [22/Jan/2003:08:16:59 -0500] UpdateJob: job 56, file 0 is complete.
> D [22/Jan/2003:08:16:59 -0500] CancelJob: id = 56
> D [22/Jan/2003:08:16:59 -0500] StopJob: id = 56, force = 0
> D [22/Jan/2003:08:16:59 -0500] StopJob: printer state is 3

Reply to: