[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

(OT, Long) Very strange behaviour with real W2k file sharing, solved by using Samba.

We have a group of W2k machines that have CADD software installed on them.

In particular, we use a program called I-DEAS, currently at version 9.

This software is installed and runs locally, and accesses our part
datafiles off a network drive mapped to T:

Under NT 4.0 on the client, this worked.  Once I upgraded the
client machine to Windows 2000, this quit working.  Same file share, etc,
nothing has changed on the server side.

No matter what I set the permissions to, even to giving the user
administrator and full control, it would not work, claiming it couldn't
open the files it needed.

The users were manually copying 2.3 gig of data files to the machine they
needed to run from, and mapping their \\ownmachine\c$ to T:, and strangely
enough this would actually work.

Enough of that!  I brought over a spare Windows 98 machine in an effort to
simplify the file sharing, shared the drive full control, and mapped the
T: drive on the client to this machine.

Still no go.  After a few hours of playing with every possible setting in
I-DEAS 9, I figured I'd do a last ditch effort.

I copied the 2.3 gig of files over to our local Linux backup server,
nano'd /etc/samba/smb.conf to setup a quick and dirty share, and
chmod'd/chown'd the files to the user.

This worked, I-DEAS was quite happy to map to T: and run and access all
the files without complaining.  Both users can access their files without

Just how weird is that, Samba works better than real windows networking.


Reply to: