[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: sound possible on Epox 8kha+ motherboard?

The following message is a courtesy copy of an article
that has been posted to alt.comp.periphs.mainboard.epox as well.

>> Did anybody ever get sound to work on your EPOX 8kha+ board with
>> debian?  I have 10/10/02 sid cds.  I can make the console beep out
>> of the speaker only.

Rico> Would you mind mailing the Output of these two Commands?
Rico> lspci; lspci -n
OK, I put it all in http://jidanni.org/comp/system.txt

L> I have never had much joy with these embedded_audio_devices on the
L> 8KHA+, the 8H5A2 (or any mobo for that matter).  When I have
L> managed to get them to work, they have never sounded that great
L> either.
L> IMHO, these embedded_audio_devices are more trouble that they are worth.
L> My approach is to disable the embedded device and to install a
L> relatively inexpensive (e.g. Ensoniq 5880 based) pci audio card.

I just traded in my old computer with its card still inside ... I'd
hate to have to make a trip to town to buy one...

One sign of trouble is I tried knoppix and it made lots of complaints
upon boot [which of course flew off the screen and are not in
/var/log...] Seems 2.4.19 is worse than 18 here...

Anyway, it must be just the IRQ's or whatever... if you have the
recipe I don't think I would notice quality issues...

I mean if I can make it beep out the speakers with
echo -e \\a>/dev/console
that means I must not be too far off?

A> Alsa 0.9.0rc6 seems to support your card, look here:
A> http://www.alsa-project.org/alsa-doc/doc-php/template.php3?company=VIA&card=&chip=via8233a&module=via82xx
A> You might have to compile it yourself, I don't know whether 0.9.0-rc6
A> is in Debian stable. I use Debain testing, there you can get a package
A> for it.

since it's not easy for me to update my SID 20021010 cd set, nor do I
dare to 'compile the kernel', might there be a way to do it with
'sox'?  One bleat will satisfy me.

P.S. wildly entering commands produces this dmesg:
Via 686a audio driver 1.9.1
ac97_codec: AC97 Audio codec, id: 0x414c:0x4710 (ALC200/200P)
via82cxxx: board #1 at 0xE400, IRQ 12
via_audio: ignoring drain playback error -512
ALSA ../../../alsa-kernel/core/seq/oss/seq_oss.c:225: can't register device seq
VIA 8233 soundcard not found or device busy
ALSA ../../alsa-kernel/drivers/mpu401/mpu401.c:70: specify snd_port
MPU-401 device not found or device busy
http://jidanni.org/ Taiwan(04)25854780

Reply to: