[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Kernel 2.4.18 image unbootable, source uncompilable



On Thu, Jan 02, 2003 at 10:18:08PM +0000, Tim wrote:
> Hi,
> 
> I have a new computer on which I am trying to use kernel 2.4.18, so far
> without success.  I can use 2.2.20-idepci without problems.  I am using
> Debian Woody rev 0, on an AMD Athlon XP 2200+, with ASUS A7N266-VM
> motherboard, which has nVidia nForce chipset-that requires 2.4.18
> kernel.  I have tried to use the kernel image as well as compiled from
> source, so far without success.
> 
> 1.  Kernel image, obtained with dselect from my installation CDs.  I
> have verified that /vmlinuz points to /boot/vmlinuz-2.4.18-k7 and
> /initrd.img points to /boot/initrd.img-2.4.18-k7.  My GrUB boot line reads:
> 
> kernel (hd0,0)/vmlinuz root=/dev/hda1 initrd=/initrd.img
> 

I think you need to execute the initrd line after the kernel load
command. For example:

grub> root (hd0,0)
grub> kernel /vmlinuz root=/dev/hda1
grub> initrd /initrd.img
grub> boot

I'm assuming /boot is not a separate partition. If it is, the grub
root should be the /boot partition. 

I always specify absolute filenames in my grub menu.lst so there is
not question about what kernel is being loaded.
 
The kernel panic message indicates the initrd.img is not loading the
modules needed by your root file system.

> The kernel panic message is:
> 
> request_module[block-major-3]: Root fs not mounted
> VFS: Cannot open root device "hda1" or 03:01
> Please append a correct "root=" boot option
> Kernel panic: VFS: Unable to mount root fs on 03:01
> 
> I have looked in /boot/config-2.4.18-k7 and found that IDE support is
> compiled as a module.  I presume my initrd doesn't use this module at
> the moment.  I am not familiar with mkinitrd so am unsure about how to
> ensure this module is installed into the initrd.  Hopefully it is a
> simple solution.  Do I have to use make config while in a specific
> directory?
> 
> 2.  Kernel compilation-I have tried multiple times with various kernel
> configurations.  Make bzImage fails to complete.  The error message
> is:

Here is a howto on compiling kernel the Debian way:

http://newbiedoc.sourceforge.net/system/kernel-pkg.html.en

-- 
Jerome

Attachment: pgpmbD6IgAIP0.pgp
Description: PGP signature


Reply to: