[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

apt-get upgrade (potato -> woody) dependency problem?

couldn't get the ~elphick/postgresql apt thingie to work, so i'm
omitting that for now (hopefully the official woody version will work)
and i went and did

	apt-get update
<all went smoothly, then>
	apt-get upgrade
	49 packages upgraded, 0 newly installed, 0 to remove and 264 not
	Sorry, but the following packages have unmet dependencies:
	  debianutils: PreDepends: libc6 (>= 2.2.4-4) but 2.1.3-24 is to be installed
	E: Internal Error, InstallPackages was called with broken packages!

is this normal? i haven't tried dselect yet, but this looks like
a bit of a bug (unless i somehow borked something myself).

I use Debian/GNU Linux version 2.2;
Linux server 2.2.17 #1 Sun Jun 25 09:24:41 EST 2000 i586 unknown
DEBIAN NEWBIE TIP #41 from Colin Watson <cjw44@flatline.org.uk>
Do you need to MASSAGE A BUNCH OF FILE NAMES? There's more
than one way to skin a cat -- here are some examples of
canonicalizing file names to lower-case:
	mmv \* \#l1
	rename 'tr/A-Z/a-z/' *
	zsh -c 'for x in *; do mv "$x" "${x:l}"; done'
(The "rename" command is a standard perl script, by the way.)

Also see http://newbieDoc.sourceForge.net/ ...

Reply to: