[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Installing a new kernel...

This one time, at band camp, alan brown said:
> I tried reconfiguring package getty but was told that it is not
> installed and has no available information
> So I did an apt-get install on it and was told that it existed in the
> database but had no available version. But that the package util-linux
> replaces it, and I have the latest version of that. 
> So I tried reconfiguring that but it ignored the command.  Perhaps it
> did everything behind the scenes, so I just rebooted. But, no, the
> same problem exists.
> The oddest thing about the whole thing is that when my blue/green
> screen comes up, I can't just do ctrl-alt-F7 to get the login screen.
> I have to do ctr-alt- Fn, and then do ctrl-alt-F7 to get it.  And then
> I log in to X, but am still unable to use the text consoles.
> I'm using kernel 2.4.18-386.  It tells me that getty doesn't exist
> but that util-linux replaces it.  Does that make sense?  It's
> definitely saying that I can't install getty, but perhaps that's
> because its supposed to be part of the kernel? 
> Any thoughts
> alan

getty apparently used to be a seperate package, but is now part of the
util-linux package.  In the absence on any additional information,
though, I think this may be barking up the wrong tree.  It sounds like
this kernel you installed may be using a framebuffer, and this is dong
screwy things to your display settings, and it's reset by leaving X and
returning to it, at a guess.

Try disabling it (pass video= options to lilo) to see if that helps.
|  Stephen Gran                  | BOFH excuse #2:  solar flares           |
|  steve@lobefin.net             |                                         |
|  http://www.lobefin.net/~steve |                                         |

Attachment: pgpWeaAXf8voj.pgp
Description: PGP signature

Reply to: