[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Problems with package dependencies.

Good Morning All,

I've got Debian 3.0 / unstable installed on my laptop and I'm having some difficulties with installing a package I need. I use Python 2.2 for a lot of small app development and a GUI toolkit for Python called wxPython (which requires Python 2.2).

Python 2.1 was installed by default. I then installed Python 2.2 as well and it's at the latest version.

mica root # apt-get install python2.2
Reading Package Lists... Done
Building Dependency Tree... Done
Sorry, python2.2 is already the newest version.
0 packages upgraded, 0 newly installed, 0 to remove and 8  not upgraded.

So now I want to install wxPython which is in the package libwxgtk2.3-python. So I try apt-get install libwx.... and it fails saying that I only have python 2.1.. instead of python 2.2. Which is true. Kind of. There is a meta package called "python" that installs the symlinks to the Python interpreter (2.1) is /usr/bin and that package is what wxPython is looking at for the version number. See below..

mica root # apt-get install libwxgtk2.3-python
Reading Package Lists... Done
Building Dependency Tree... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

Sorry, but the following packages have unmet dependencies:
libwxgtk2.3-python: Depends: python (>= 2.2) but 2.1.3-4 is to be installed
E: Sorry, broken packages

I've tried removing / upgrading the "python" package it's a dependency for half my system (KDE, and a lot of other stuff) so I can't really remove it. How can I convince the libwxgtk to install properly?


Reply to: