[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

SOLVED: Debian cannot find the CD

Hello all

The problem described at the bottom of the page and posted to this mail list
about a week ago, was solved in the following way.

The command:
#dmesg | grep CD
reported that the CD was at   /dev/hdb

I did try:
#ls -l /dev/cdrom
and recieved a message saying there was no such device.

Then from su (or root) the command:
#ln -s /dev/hdb /dev/cdrom
enabled the CD  to work fine!

Many thanks to those who contributed to solving my problem.


----- Original Message -----

Hello all

Debian cannot find the CD drive (though Windows 98 can) so I have used the
vi editor to change the file system table. Unfortunately, the CD is still
not being found by Debian.

I have changed the line in /etc/fstab
/dev/cdrom    /cdrom     iso9660 defaults,noauto         0  0
/dev/cdrom    /cdrom     iso9660 defaults,noauto,users        0  0

After restarting the computer, putting a cd in its drive and double clicking
on the cd icon, I get the message:
"mount: special device /dev/cdrom does not exist"

If anyone can see what I might be doing wrong then please let me know.


Reply to: