[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

problem compiling a new gcc version.


I'm running woody with a 2.2.20 kernel. Recently I tried to install a newer gcc (3.2). I used these commands:
mkdir /usr/gcc-3.2/
cd /usr/gcc-3.2/
/opt/gcc-3.2/configure --with-local-prefix=/usr/src/kernel-headers-2.2.20/include --prefix=/usr
make (or make bootstrap, tried them both)

configure detects no error, but during make I get this:
In file included from /opt/gcc-3.2/libstdc++-v3/src/locale.cc:406:
/usr/gcc-3.2/i686-pc-linux-gnu/libstdc++-v3/include/i686-pc-linux-gnu/bits/ctype_noninline.h: In
   static member function `static const short unsigned int* 
/usr/gcc-3.2/i686-pc-linux-gnu/libstdc++-v3/include/i686-pc-linux-gnu/bits/ctype_noninline.h:45: `
   __ctype_b' undeclared (first use this function)
/usr/gcc-3.2/i686-pc-linux-gnu/libstdc++-v3/include/i686-pc-linux-gnu/bits/ctype_noninline.h:45: (Each
   undeclared identifier is reported only once for each function it appears 
/usr/gcc-3.2/i686-pc-linux-gnu/libstdc++-v3/include/i686-pc-linux-gnu/bits/ctype_noninline.h: In
   constructor `std::ctype<char>::ctype(int*, const short unsigned int*, bool, 
   unsigned int)':
/usr/gcc-3.2/i686-pc-linux-gnu/libstdc++-v3/include/i686-pc-linux-gnu/bits/ctype_noninline.h:61: `
   __ctype_toupper' undeclared (first use this function)
/usr/gcc-3.2/i686-pc-linux-gnu/libstdc++-v3/include/i686-pc-linux-gnu/bits/ctype_noninline.h:61: `
   __ctype_tolower' undeclared (first use this function)
make[4]: *** [locale.lo] Fout 1
make[4]: Leaving directory `/usr/gcc-3.2/i686-pc-linux-gnu/libstdc++-v3/src'
make[3]: *** [all-recursive] Fout 1
make[3]: Leaving directory `/usr/gcc-3.2/i686-pc-linux-gnu/libstdc++-v3'
make[2]: *** [all-recursive-am] Fout 2
make[2]: Leaving directory `/usr/gcc-3.2/i686-pc-linux-gnu/libstdc++-v3'
make[1]: *** [all-target-libstdc++-v3] Fout 2
make[1]: Leaving directory `/usr/gcc-3.2'
make: *** [bootstrap] Fout 2

could it be that this is specific to my kernel or is it a configuration problem with my current locales?
I hope this is not too specific, I could mail to the gcc people but I haven't had this problem under other
systems so I figured it might be a misconfiguration somewhere?

thx in advance,

Reply to: