[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Debian3.0, Win2000 and LILO problem

I have Pentium IV, HD  40 GB. 
First Windows2000 professional was installed on first 30 GB of the HD
(on hda1).
Then on hda3 (10GB ) I installed Debian3.0 (current stable) 
using compact floppies and then via ftp.
I chose (in the end of the installation process) to use 
menu version of LILO and  to install it (LILO's boot block) in /dev/hda3.
Linux was loaded default and Win2000 as other. I changed it manually
editing lilo.conf so Win200 was loaded default and Linux as other.
It worked fine. I compiled the kernel-2.4.18 ( from resources )
and run lilo and still it worked fine (I mean Win2000 and Linux
was loaded properly).

After one day when I switch on the computer I saw the following:
Verifying DMI Pool Data....
Boot from CD:
and computer hanged.
(in BIOS the sequence boot is: floppy, CD, HH0).

I tried to use the boot floppy to load linux but it did not
work, instead sequence of zeros appeared: 000000000....000...so on.
The rescue floppy did not work either (the same behavior as in case
of boot floppy, boot: 00000...so on). But when I used Backspace to delete
the appeared zeros they did not appeared again and 
boot: rescue root=/dev/hda3 worked and the linux kernel was loaded.
When I tried to run lilo I got the following message:
Warning: Int 0x13 function 8 and function 0x48 return different
head/sector geometries for BIOS drive 0x80
Added Linux
Added Win2000(hda1) *

But it changed nothing. So I run: 'lilo -u' to uninstall LILO
and change in lilo.conf the line
boot=/dev/hda3 to be boot=/dev/hda.

I run lilo (got the message as above: Warning: Int 0x13 function 8 and
but now something changed: The coloured LILO menu appeared,
after the line (on the screen) boot: 
sequence of zeros appeared: 000000000....000...so on 
but  when I used Backspace to delete the appeared zeros they did not 
appeared again and  I could choose which OS to load and they 
both seem to load properly.

Question: Could someone please to help to configure LILO properly
and get rid off the ''problem of zeros'' and to make happy LILO
not to complain:   Warning: Int 0x13 function 8 and ...?


P.S. My lilo.conf without most comments.

# /etc/lilo.conf - See: `lilo(8)' and `lilo.conf(5)',
# ---------------       `install-mbr(8)', `/usr/share/doc/lilo/',
#                       and `/usr/share/doc/mbr/'.

# +---------------------------------------------------------------+
# |                        !! Reminder !!                         |
# |                                                               |
# | Don't forget to run `lilo' after you make changes to this     |
# | conffile, `/boot/bootmess.txt', or install a new kernel.  The |
# | computer will most likely fail to boot if a kernel-image      |
# | post-install script or you don't remember to run `lilo'.      |
# |                                                               |
# +---------------------------------------------------------------+

# Support LBA for large hard disks.

# Overrides the default mapping between harddisk names and the BIOS'
# harddisk order. Use with caution.
#    bios=0x81

#    bios=0x80

# Specifies the boot device.  This is where Lilo installs its boot
# block.  It can be either a partition, or the raw device, in which
# case it installs in the MBR, and will overwrite the current MBR.

# Specifies the device that should be mounted as root. (`/')
# root=/dev/hda3


# Specifies the location of the map file
# map=/boot/map

# delay=20

# timeout=150
#	prompt
#	single-key
#	delay=100
#	timeout=100

# Specifies the VGA text mode at boot time. (normal, extended, ask,
# vga=ask
# vga=9

# append=""

# Boot up Linux by default.

#	restricted
#	alias=1

# image=/vmlinuz.old
#	label=LinuxOLD
#	read-only
#	optional
#	restricted
#	alias=2

# If you have another OS on this machine to boot, you can uncomment the
# following lines, changing the device name on the `other' line to
# where your other OS' partition is.
# other=/dev/hda4
#	label=HURD
#	restricted
#	alias=3

Reply to: