[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Weird problem with self-compiled kernel

Dear Debian Users,

I'm using Debian 3.0r0 SID using a 2.4 kernel.

Initially Debian installed with the 2.4.18-bf24 kernel. 
Because I needed the 2.4.19 kernel for various reasons I got it from www.kernel.org

The steps I did:

-untar the kernel to /usr/src/linux-2.4.19
-make a symlink from /usr/src/linux-2.4.19 to /usr/src/linux

make clean
make dep
make bzImage
make install
make modules
make modules_install

I made sure everything was right in the /etc/lilo.conf and after that I ran "lilo".
After a reboot I typed: uname -a 
The output is: Linux p4-1700 2.4.19 #2 SMP Mon Nov 4 21:00:46 CET 2002 i686 unknown unknown GNU/Linux
Looks nice heh ;)

Everything works fine. But the problem is that I can't connect to certain sites.
Eg. When I type "lynx www.openoffice.org" he tries to make a http connection but nothing happens.
Also when I type "lynx www.davitel.nl" it goes wrong. All other site I have tried do work perfectly.
When I switch back to 2.4.18-bf24 I can connect to the sites that don't work in 2.4.19.
No weird things in /etc/hosts.deny or .allow 
My firewallserver is straight forward so that shouldn't be a problem either. All other computers in the network don't have problems. 

It only goes wrong with the 2.4.19 kernel. 2.4.20 also doesn't work.
I included the config file I used to compile the kernel.

Can somebody help me out of this weirdness ?

Thanks in advance.

Patrick Brunier

Attachment: config-2.4.19
Description: Binary data

Reply to: