[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Woody, XFree 4.1, & GL apps (Dell Optiplex system)

Hi all;

My system was just refreshed; I now have a Dell Optiplex GX240.  This
system comes with some slightly odd version of an ATI Rage 128 video
card, which uses a different chip ID than the 4.1.0 X servers are
expecting.  In order to make this work I added a line to my XF86Config-4
Device section:

  Section "Device"
	Identifier	"Generic Video Card"
	Driver		"ati"
	ChipID		0x05246

This works really well, even at high resolutions like 1600x1200.


Earlier today I found my system screen blank and no amount of keyboard
pounding or mouse tweaking could wake it up.  I thought my system had
crashed, but when I tried to log in from another system it worked fine.
I found that there was a GL xscreensaver hack running, taking up 99% cpu
but not displaying anything.  I killed it and my system was fine.  I
tried starting another GL screensaver hack and the same thing happened:
this time it was not on the root window so I was able to determine the
entire X server was locked: I couldn't move my mouse or anything.  Had
to log in remotely again to kill it.

I've uninstalled the xscreensaver-gl package for now, but I'd really
like to get this working again.

Anyone have any thoughts or ideas about what might be causing this?  My
old system was able to run GL hacks with no problems, although it used a
different video card so that's not saying much.

Where should I look?  GL library issues?  Try to get a 4.2.0 version of
the server?

Anyone else seeing this or have ideas?

 Paul D. Smith <pausmith@nortelnetworks.com> HASMAT--HA Software Mthds & Tools
 "Please remain calm...I may be mad, but I am a professional." --Mad Scientist
   These are my opinions---Nortel Networks takes no responsibility for them.

Reply to: