[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

About to give up: No X after upgrade from Potato to Woody

I'm afraid I've had no luck and am afraid I may only be digging a deeper
hole for myself at this point. X was working beautifully for a year before I
upgraded. I did try to use the old XF86Config file but kept getting errors
about "/dev/mouse unable to get status of mouse fd (inappropriate ioctl for
device". I then got errors about "/usr/X11R6/lib/X11/xinit/xinitrc: gmc not
found" and then "panel" not found. Those last two errors were from lines in
my Xsession file and I put them in so long ago I no longer remember what
they did. I believe they are what I needed to get GNOME to start.

I've commented them out and so don't get them anymore though X still doesn't
start because of the "unable to get status of mouse fd" error. Some research
on the archives led me to suspect that was related to gpm, something I'm not
that familiar with. Based on what I read I don't need gpm since I use X and
so I killed gpm. But still the errors continued.

At this point the only clue I have as to how to proceed is in regard to the
mouse. I've fiddled with its settings in /dev, trying various links   since
I no longer remember what it was when it worked. At one point after I'd
linked /dev/mouse to /tty0 I think, X no longer gave me the errors. But at
the same time it immediately shut down, i.e. it ran through all the startup
messages then said it was shutting down.

Though I've spoken highly of Debian in the past I'm coming to the conclusion
that it's only for people who have the time to learn every bit of arcana
regarding every bit of their software and hardware. There's something good
about that and I'm happy such a distribution exists. But I'm also realizing
I don't have the time to go through this every time I want to make a change
on my system and it may just not be the distribution for me. I'm going to
spend a few more days on this but if I don't get it fixed after that I may
have to try something else.

-----Original Message-----
From: David Teague [mailto:dbt@cs.wcu.edu]
Sent: Friday, July 26, 2002 11:49 AM
To: kenjanuski@mindspring.com
Subject: Re: No X after upgrade from Potato to Woody


I upgraded from 2.1 to 2.2, and "it" reinstalled my Xserver, Apparently
there was no (direct) support in the X for 2.2 for my video card (SIS
6326). The Xconfig file formats were not compatible as I found later.
Unfortunately there was no warning in the install.

I replaced the server with the earlier one and things worked, When it came
time to upgrade to Woody, the person doing the upgrade knew what he was
doing, and all came out working. I have to learn that.

Please let me know what your problem was and the resolution.


On Thu, 25 Jul 2002 kenjanuski@mindspring.com wrote:

> Date: Thu, 25 Jul 2002 16:35:12 -0400
> From: kenjanuski@mindspring.com
> To: Stephen Gran <gashuffer09@comcast.net>
> Cc: Debian <debian-user@lists.debian.org>
> Subject: Re: No X after upgrade from Potato to Woody
> Resent-Date: Thu, 25 Jul 2002 16:35:49 -0400
> Resent-From: debian-user@lists.debian.org
> Thanks Steven,
> Back here at band camp I've followed your suggestions and found a number
> related threads in archives. "dpkg-reconfigure xcommon-server" was
> and that told me that xcommon-server wasn't fully installed. so i used
> to install it, found i needed to remove 40 packages and get 30, did so and
> then made the mistake of letting debconf write my XF86Config file. But at
> least that is now giving me some useful error messages when I try startx
> so I'm editing new config file to reflect the old one that worked. I'm
> that will solve it.
> But work has intervened and I have to wait about 8 hours to get back to
> Thanks for your advice.
> Ken
> On Thu, 25 Jul 2002 13:53:18 -0400 Stephen Gran <gashuffer09@comcast.net>
> wrote:
> This one time, at band camp, Ken Januski said:
> > First of all sorry for using Outlook. But the upgrade seems to have
killed X
> > and Netscape which I use for email.
> >
> > Anyway I used apt-get update, then apt-get dist-upgrade, then apt-get
> > dist-upgrade fix-missing, when I was told some packages were missing.
> > Eventually I got to the point where it seemed all errors were taken care
> >
> > But I guess these errors when running startx:
> >
> > X: Unable to open wrapper config file /etc/X11/XWrapper.config
> > X: cannot stat /etc/X11/X no such file or directory
> > xinit: connection refused (errno 111): unable to connect to X server
> > xinit: no such process (errno 3): server error
> >
> > I wonder if this could have been caused by fact that I inadvertently had
> > running on an alternate screen when running the update.
> >
> > But my real question: How do I fix it?
> >
> > Thanks for any ideas,
> >
> > Ken
> I think I've seen this in the list before - you might try searching the
> archives.  Off the top of my head, I seem to remember that some of the X
> packages get accidentally removed during the upgrade.  Try xlibs and
> xbase-clients in particular, IIRC.
> HTH,
> Steve
> --
> That secret you've been guarding, isn't.
> --
> To UNSUBSCRIBE, email to debian-user-request@lists.debian.org
> with a subject of "unsubscribe". Trouble? Contact

To UNSUBSCRIBE, email to debian-user-request@lists.debian.org 
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: