[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Emacs from Xterm

also sprach Bill Spears <bspears@easystreet.com> [2002.07.04.2321 +0200]:
> I've finally gotten Debian (and KDE) up and was about to burn a CD when  I 
> discovered that I didn't have cdrecord installed.  apt-get worked 
> beautifully. But then I found I didn't have ide-scsi installed.  So I tried 
> emacs /etc/lilo.conf from an xterm and got error: emacs couldn't connect to 
> Xserver and some suggestions about xhost, which didn't work. So I used vi and 
> it worked. But I like to use emacs (it does work from the menus), and I need 
> to use it as root sometimes (anybody knowing how to use a user started Emacs 
> process as root) please jump in). I figured this is an X security problem, 
> but still don't know what to do. 

`xhost +localhost` as the user before you `su` to use emacs.

martin;              (greetings from the heart of the sun.)
  \____ echo mailto: !#^."<*>"|tr "<*> mailto:"; net@madduck
your eyes are weary from staring at the CRT. you feel sleepy. notice
how restful it is to watch the cursor blink. close your eyes. the
opinions stated above are yours. you cannot imagine why you ever felt

Attachment: pgpr0cGavGYxc.pgp
Description: PGP signature

Reply to: