[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

sequencers in Debian Woody

i'm terribly sorry for the re-post, but i just realized i subscribe
from LAU with different email-address, and thus this email didn't get
through.. (and i even cross-post... argh)


hello Linux audio users and fellow debianists

about a month ago i upgraded my system from Debian Potato to Woody,
looking forward to see all the interesting sound applications people
have been writing, and which ones of those have been packaged for
Debian.  overall, i've been fairly happy with them, with the exception
of all the four sequencers in Woody: Sted2, Rosegarden, Brahms and

i hope i'm not expecting too much from any of these:  all i want to do
is to record my playing from the midi-keyboard while using Timidity as
a soft synth, and then being able to save my playing as a midi-file.
my Ensoniq ES1371 [AudioPCI-97] sound card doesn't have a built-in
synth, so i have to use Timidity (or something similar).  my
midi-keyboard is known as "MK-61 midi keyboard controller", with
15-pin "midi port", connected to the soundcard that also feeds power
to the keyboard

there doesn't appear to be any hardware problem, as i can do 'cat
/dev/sequencer' and i get some output, "test audio and midi" in PD
assures me that at least PD can read my midi-keyboard correctly, and
(more convincingly) 'timidity -iA -B 2,8 -Os && aconnect 64:0 128:0'
enables me to drive Timidity with the keyboard.  yet despite these i'm
still unable to do any midi-recording with any of these sequencers
while rendering my playing with Timidity

some info on my configurations:  i'm using 2.4.18 kernel and i've
tried using both ALSA 0.5.12a-2 and 0.9+0beta10-6.
my /etc/alsa/modutils/0.5 and /etc/alsa/modutils/0.9 are identical:

# --- BEGIN: Generated by ALSACONF, do not edit. ---
# --- ALSACONF verion 0.4.3b ---
alias char-major-116 snd
alias snd-card-0 snd-card-ens1371
alias char-major-14 soundcore
alias sound-slot-0 snd-card-0
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss
options snd snd_major=116 snd_cards_limit=2 snd_device_mode=0660 snd_device_gid=29 snd_device_uid=0
options snd-card-ens1371 snd_index=0 snd_id=ENSONIQ
# --- END: Generated by ALSACONF, do not edit. ---

# virtual midi:
alias snd-card-1 snd-card-virmidi
alias sound-slot-1 snd-card-1
options snd-card-virmidi snd_index=1 snd_id=VIRTUAL_MIDI

okay, here's my experiences with all these four sequencers:

Sted2 (2.07m+20010303-3) [ALSA 0.5 and 0.9]:  (note: Sted2 has to be
patched or run as 'LC_CTYPE=C sted2' or something similar in a
scandanavian environment when using X.)  i have configured it with a
line 'player=1,timidity -id -f -EFchorus=0 -EFreverb=0 -s44.1 -Os' in
/etc/sted2/sted2.cnf, and it can load and play midi-files without a
problem.  while using either the default setting or
'midi_port=/dev/sequencer', it informs me with 'MIDI IN : midi' in the
main screen.  after choosing a track and while trying to record into
it, it responds to my first keyboard press with a ticking metronome.
i hit my keyboard but no sound comes out nor actual recording happens.
i can stop this by pressing reset.  during this so-called recording
sted2 consumes all the CPU power available.  the track remains empty,
even though i tried switching recording channels, output mode
(thru/off) and sync (int/ext).  with 'midi_port=/dev/midi' it tells me
'MIDI IN : NoConnect' and doesn't react at all

Rosegarden (2.1pl3-1) [both 0.5 and 0.9]:  quite like Sted2.  in 'MIDI
Setup' it prefers /dev/sequencer.  i can start Timidity in the
background as ALSA sequencer interface mode, and direct the playing
into Timidity port 0.  the playing works without much problems (there
may be some caused by bad latencies).  when trying to record from
"MIDI 0-0", it just hangs and i have to kill the sequencer process.
switching MIDI 0-0 to "Timidity port 0" doesn't help either

Brahms (1.02-3) [ALSA 0.5]:  documentation says that only version of
ALSA it can be run with is 0.5.x.  when run with 'brahms -o alsa', i
cannot choose any options for the output of the tracks, and when
trying to play an imported midi-file brahms doesn't indicate it's
going forward.  when trying to record nothing moves forward

Brahms [ALSA 0.9]: the binary uses the libasound.so.2 -shared library,
suggesting it needs something from ALSA 0.9 (?), so i gave it a try.
it does run, but behaves just like with ALSA 0.5

Brahms [libarts-alsa & ALSA 0.9]: i can record and play with this,
using arts instruments as synths.  nice, promising, but ready-made
arts instruments sound horrible, and i haven't yet bothered to look
artsbuilder.  is there a way to connect this to Timidity?  (Timidity
is of version 2.10.4-2.2, and it doesn't have arts-plugin)

Muse (0.5.2-1) [ALSA 0.5]:  the binaries in Debian won't work with
ALSA 0.5, and there doesn't appear to be a command line option to
switch to use OSS-emulation

Muse [ALSA 0.9]: i can create a track, add iiwu-1 instance to soft
synths -list, add it to a midi-port table and then i have to switch
device name to MIDI 0-0 so that i can mark it as a recording source.
i mark the new track as a recording track.  while trying to record i
have no luck, recording appears to go forward but nothing gets into
the track.  and i have no idea how i could set up timidity with this
(maybe soft synths in muse are okay, i cannot say)

i admit i could look a little deeper into muse, but so far i've
preferred ALSA 0.5, because Soundtracker, Ecasound and Timidity in
Woody are compiled for 0.5, and i'm quite probably going to use these
apps a lot (i know that at least Ecasound can be compiled for ALSA
0.9, i'm not sure about the other two)

so, does any of you have any suggestions what i should try to do with
these sequencers?  are there any other apps out there that i should
try out?  (jazz?)  is there any simple app that records what i play
into a midi-file and lets me direct it into timidity at the same time?

sorry for a rather lengthy post, clogging all your mailboxes.  i'm
thankful for all your suggestions

To UNSUBSCRIBE, email to debian-user-request@lists.debian.org 
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: