[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: I hate printers

On Mon, 2002-04-01 at 20:56, Tom Allison wrote:
> I have tried repeatedly to get the lpr & /etc/printcap configured to 
> print correctly.  The closest I can get is to have the stupid computer 
> come back and say that it can't find the printer lp@
> I am using a D-Link DL713P as the printer server.

An HP LJ1000 plugged into a DLink DP101 works _perfectly_ for

First, of course, I had to create a queue on the print server.
Then, put the server name in /etc/hosts (called it netprn1).

Have you installed these debian packages?
  cupsys                   1.1.14-3
  cupsys-bsd               1.1.14-3
  cupsys-client            1.1.14-3
  cupsys-pstoraster        1.1.14-3
  gtklp                    0.9-1
  libcupsys2               1.1.14-3
  libcupsys2-dev           1.1.14-3

Since you were so inconsiderate as to not tell us what kind of
printer you have, I'll trundle on pretending you have an HP LJ.

After you install those packages, open up http://localhost:631.
When I added a printer in CUPS (imaginately and easily named "lp"),
I set
  Device: LPD/LPR Host or Printer
  Device URI: lpd://netprn1/netprn1-p1
  Set it to an HP printer, and was off to the races.

No need for apsfilter, or any of that other stuff.  Mozilla, 
OpenOffice, AbiWord, etc all print great using lp.  (Haven't
tried Gimp; no need to.)

> What really cooks my goose is that I have already had several people 
> tell me that it's exactly going to be lp@
> I have been trying to use apsfilter to configure the lpr printcap 
> file.  The only thing that seems to be out of sorts is the idea that 
> the printer name on the remote server is lp and apsfilter prefers the 
> name raw.
> printers are really weird and I've tried RTM-ing.  But I've seen 
> nothing worse for a read that that.  bother!
> And yes, I tried CUPS.  That really didn't work.  I was trying to send 
> the print job to the ipp port and not the printer port (515, not lpt). 
>   And there is ZERO documentation on CUPS.  Yes, I went to the site. 
> Event read half the fricken white papers before I realized that it 
> wasn't going to help me a bean.
> I am at a loss.  I don't know I'm supposed to "try" next.  I've done 
> this a number of times with real servers.
> If anyone has any suggestions, I'm open.  I'm also totally stuck!

| Ron Johnson, Jr.        Home: ron.l.johnson@cox.net        |
| Jefferson, LA  USA      http://ronandheather.dhs.org:81    |
|                                                            |
| "Whatever may be the moral ambiguities of the so-called    |
|  demoratic nations and however serious may be their failure|
|  to conform perfectly to their democratic ideals, it is    |
|  sheer moral perversity to equate the inconsistencies of a |
|  democratic civilization with the brutalities which modern |
|  tyrannical states practice."                              |
|       Reinhold Nieburhr, ca. 1940                          |

To UNSUBSCRIBE, email to debian-user-request@lists.debian.org 
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: